HDU 2757 Ocean Currents

39 篇文章 0 订阅
Problem Description
For a boat on a large body of water, strong currents can be dangerous, but with careful planning, they can be harnessed to help the boat reach its destination. Your job is to help in that planning.

At each location, the current flows in some direction. The captain can choose to either go with the flow of the current, using no energy, or to move one square in any other direction, at the cost of one energy unit. The boat always moves in one of the following eight directions: north, south, east, west, northeast, northwest, southeast, southwest. The boat cannot leave the boundary of the lake. You are to help him devise a strategy to reach the destination with the minimum energy consumption.
 

Input
The lake is represented as a rectangular grid. The first line of each test chunk contains two integers r and c, the number of rows and columns in the grid. The grid has no more than 1000 rows and no more than 1000 columns. Each of the following r lines contains exactly c characters, each a digit from 0 to 7 inclusive. The character 0 means the current flows north (i.e. up in the grid, in the direction of decreasing row number), 1 means it flows northeast, 2 means east (i.e. in the direction of increasing column number), 3 means southeast, and so on in a clockwise manner:

7 0 1
\|/
6-*-2
/|\
5 4 3

The line after the grid contains a single integer n, the number of trips to be made, which is at most 50. Each of the following n lines describes a trip using four integers rs, cs, rd, cd, giving the row and column of the starting point and the destination of the trip. Rows and columns are numbered starting with 1. 

Please process to the end of the data file.
 

Output
For each trip, output a line containing a single integer, the minimum number of energy units needed to get from the starting point to the destination.
 

Sample Input
  
  
5 5 04125 03355 64734 72377 02062 3 4 2 4 2 4 5 1 4 5 3 3 4 5 5 04125 03355 64734 72377 02062 3 4 2 4 2 4 5 1 4 5 3 3 4
 

Sample Output
  
  
0 2 1 0 2 1

相当于找最短路,加个优先队列优化一下。

#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define rep(i,j,k) for (int i=j;i<=k;i++)
const int INF=0x7FFFFFFF;
const int sz=1005;
int n,m,t,bx,by,ex,ey;
int mp[sz][sz],f[sz][sz];
char s[sz];
int x[8]={-1,-1,0,1,1,1,0,-1};
int y[8]={0,1,1,1,0,-1,-1,-1};

struct point
{
    int x,y,z;
    point(int x=0,int y=0,int z=0):x(x),y(y),z(z){};
    bool operator<(const point &a) const 
    {
        return z>a.z;
    }
};

int main()
{
    while (~scanf("%d%d",&n,&m))
    {
        memset(mp,-1,sizeof(mp));
        rep(i,1,n) 
        {
            scanf("%s",s+1);
            rep(j,1,m) mp[i][j]=s[j]-'0';
        }
        scanf("%d",&t);
        while (t--)
        {
            scanf("%d%d%d%d",&bx,&by,&ex,&ey);
            rep(i,1,n) rep(j,1,m) f[i][j]=INF;
            priority_queue<point> p;
            p.push(point(bx,by,f[bx][by]=0));
            while (!p.empty())
            {
                point q=p.top(); p.pop();
                if (q.x==ex&&q.y==ey) 
                {
                    printf("%d\n",f[ex][ey]);
                    break;
                }
                rep(i,0,7) 
                {
                    int X=q.x+x[i],Y=q.y+y[i];
                    if (mp[X][Y]==-1) continue;
                    if (f[X][Y]>f[q.x][q.y]+(i!=mp[q.x][q.y]))
                    {
                        f[X][Y]=f[q.x][q.y]+(i!=mp[q.x][q.y]);
                        p.push(point(X,Y,f[X][Y]));
                    }
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值