HDU 5543 Pick The Sticks

Description

The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it. 

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang. 

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container. 

Formally, we can treat the container stick as an  L  length segment. And the gold sticks as segments too. There were many gold sticks with different length  a_{i}  and value  v_{i} . Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks. 

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container. 

Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases,  T(1≤T≤100) T  test cases follow. Each test case start with two integers, N(1≤N≤1000)  and  L(1≤L≤2000) , represents the number of gold sticks and the length of the container stick.  N  lines follow. Each line consist of two integers,  a_{i}(1≤a_{i}≤2000)  and  v_{i}(1≤v_{i}≤10^{9}) , represents the length and the value of the  i_{th}  gold stick.

Output

For each test case, output one line containing  Case #x: y, where  x  is the test case number (starting from 1) and  y  is the maximum value of the gold sticks Xiu Yang could have taken.

Sample Input

4

3 7
4 1
2 1
8 1

3 7
4 2
2 1
8 4

3 5
4 1
2 2
8 9

1 1
10 3

Sample Output

Case #1: 2
Case #2: 6
Case #3: 11
Case #4: 3
可以看出,最多有两根棍子是可以半价放入的,其余的可以看做是01背包,所以加一维做01背包就好了。
#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
#define lson x << 1, l, mid
#define rson x << 1 | 1, mid + 1, r
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF / 3;
const int mod = 1e9 + 7;
const int N = 4e3 + 10;
const int read() 
{
	char ch = getchar();
	while (ch<'0' || ch>'9') ch = getchar();
	int x = ch - '0';
	while ((ch = getchar()) >= '0'&&ch <= '9') x = x * 10 + ch - '0';
	return x;
}
int T, n, m, cas = 0;
int x, y;
LL dp[N][3];

int main()
{
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &m, &n);
		memset(dp, 0, sizeof(dp));
		n <<= 1;
		while (m--)
		{
			scanf("%d%d", &x, &y);
			int z = x << 1;
			if (x > n) dp[n][2] = max(dp[n][2], 1LL*y);
			per(i, n, x)
			{
				if (i >= z) dp[i][2] = max(dp[i][2], max(dp[i - z][2], dp[i - x][1]) + y);
				else dp[i][2] = max(dp[i][2], dp[i - x][1] + y);
			}
			per(i, n, x)
			{
				if (i >= z) dp[i][1] = max(dp[i][1], max(dp[i - z][1], dp[i - x][0]) + y);
				else dp[i][1] = max(dp[i][1], dp[i - x][0] + y);
			}
			per(i, n, z) dp[i][0] = max(dp[i][0], dp[i - z][0] + y);
		}
		printf("Case #%d: %lld\n", ++cas, dp[n][2]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值