HDU - 5543 - Pick The Sticks(DP)

Pick The Sticks

Time Limit: 15000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2484    Accepted Submission(s): 826


Problem Description
The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an  L  length segment. And the gold sticks as segments too. There were many gold sticks with different length  ai  and value  vi . Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?
 

Input
The first line of the input gives the number of test cases,  T(1T100) T  test cases follow. Each test case start with two integers,  N(1N1000)  and  L(1L2000) , represents the number of gold sticks and the length of the container stick.  N  lines follow. Each line consist of two integers,  ai(1ai2000) and  vi(1vi109) , represents the length and the value of the  ith  gold stick.
 

Output
For each test case, output one line containing  Case #x: y, where  x  is the test case number (starting from 1) and  y  is the maximum value of the gold sticks Xiu Yang could have taken.
 

Sample Input
  
  
4 3 7 4 1 2 1 8 1 3 7 4 2 2 1 8 4 3 5 4 1 2 2 8 9 1 1 10 3
 

Sample Output
  
  
Case #1: 2 Case #2: 6 Case #3: 11 Case #4: 3
Hint
In the third case, assume the container is lay on x-axis from 0 to 5. Xiu Yang could put the second gold stick center at 0 and put the third gold stick center at 5, so none of them will drop and he can get total 2+9=11 value. In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1], and he can get the value of 3.
 

Source
 

题意:有一个长度为L的长条状容器,有N条金条,在容器的同一位置不能放置两条金条,每条金条有各自的长度和价值,金条可以从容器中冒出(冒出只能在容器两端),单其重心要在容器内,问最多可以获得多少价值的金条


所有的状态有 无金条冒出,一边有金条冒出,两边均有金条冒出(可能是两根不同的或同一根溢出两边,为了便于处理将金条长度一半大于等于容器长度的先排除了)

每条金条有 不放、全放容器内、放一半在容器内 三种放置方式

dp[i][j][k] 代表放到第 i 根金条,容器大小为 j 有 k (0 ≤ k ≤ 2) 根金条冒出 时的最大价值

状态转移方程就是 dp[i][j][k] = max(dp[i-1][j][k], dp[i-1][j-a[i]][k], dp[i-1][j-a[i]/2][k-1]);

然后处理时避免出现在金条长度/2后有小数,将金条长度和容器长度均乘二

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define LL long long
const int N = 1e3 + 10;
int t,n,m,cas = 0,sz;
LL w[N],v[N],dp[N*4][5],ans;
int main()
{
    for(scanf("%d",&t);t--;){
        memset(dp,0,sizeof dp);
        ans = sz = 0;
        scanf("%d%d",&n,&m);
        m *= 2;
        for(int i=0;i<n;i++){
            scanf("%lld%lld",&w[sz],&v[sz]);
            if(w[sz]<=m) w[sz++] *= 2;
            else ans = max(ans,v[sz]);
        }
        for(int i=0; i<sz; i++){
            for(int j=m; j>=w[i]/2; j--){
                for(int k=2; k>=0; k--){
                    if(j>=w[i]) dp[j][k] = max(dp[j][k], dp[j-w[i]][k]+v[i]);
                    if(k>0) dp[j][k] = max(dp[j][k], dp[j-w[i]/2][k-1]+v[i]);
                }
            }
        }
        ans = max(ans, dp[m][2]);
        printf("Case #%d: %lld\n",++cas,ans);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值