Kindergarten Counting Game

Description


 Kindergarten Counting Game 

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9


解题报告

题目的原型应该是统计单词,直接就敲一段统计单词的代码进行修改,一开始在那三个点的地方出问题,想使用ctype.h中的isalpha()函数写的,结果WA了,就用最土的办法。。。


#include<stdio.h>
int main()
{
    char str[81];
    int i,j,word,count;
    while(gets(str)!=NULL)
    {
        count=0;
        word=0;
        for(i=0;str[i]!='\0';i++)
            if(!(str[i]>='a'&&str[i]<='z'||str[i]>='A'&&str[i]<='Z') )
                word=0;
            else if((str[i]>='a'&&str[i]<='z'||str[i]>='A'&&str[i]<='Z') && word==0)
            {
                 count++;
                 word=1;
            }
                    
        printf("%d\n",count);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值