POJ1988:Cube Stacking(并查集)

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 24664 Accepted: 8652
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


思路:简单并查集,num[i]记录i点距离根节点多远,sum[i]记录i的儿子+自己数量。

# include <iostream>
# include <cstring>
# include <cstdio>
# include <algorithm>
# define MAXN 30000
using namespace std;
int pre[MAXN+1], sum[MAXN+1], num[MAXN+1];
int find(int x)
{
    if(x == pre[x])
        return pre[x];
    else
    {
        int t = pre[x];
        pre[x] = find(pre[x]);
        num[x] = num[t] + num[x];
        return pre[x];
    }
}

int main()
{
    int p, a, b;
    char c;
    while(~scanf("%d",&p))
    {
        for(int i=1; i<=MAXN; ++i)
        {
            pre[i] = i;
            sum[i] = 1;
            num[i] = 0;
        }
        while(p--)
        {
            getchar();
            c = getchar();
            if(c == 'M')
            {
                scanf("%d%d",&a,&b);
                int px = find(a);
                int py = find(b);
                if(px != py)
                {
                    pre[px] = py;
                    num[px] = sum[py];
                    sum[py] += sum[px];
                }
            }
            else
            {
                scanf("%d",&a);
                find(a);
                printf("%d\n",num[a]);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值