AtCoder:11(数论 & 思维)

D - 11


Time limit : 2sec / Memory limit : 256MB

Score : 600 points

Problem Statement

You are given an integer sequence of length n+1a1,a2,…,an+1, which consists of the n integers 1,…,n. It is known that each of the n integers 1,…,n appears at least once in this sequence.

For each integer k=1,…,n+1, find the number of the different subsequences (not necessarily contiguous) of the given sequence with length k, modulo 109+7.

Notes

  • If the contents of two subsequences are the same, they are not separately counted even if they originate from different positions in the original sequence.

  • A subsequence of a sequence a with length k is a sequence obtained by selecting k of the elements of a and arranging them without changing their relative order. For example, the sequences 1,3,5 and 1,2,3 are subsequences of 1,2,3,4,5, while 3,1,2 and 1,10,100 are not.

Constraints

  • 1n105
  • 1ain
  • Each of the integers 1,…,n appears in the sequence.
  • n and ai are integers.

Input

Input is given from Standard Input in the following format:

n
a1 a2 ... an+1

Output

Print n+1 lines. The k-th line should contain the number of the different subsequences of the given sequence with length k, modulo 109+7.


Sample Input 1

Copy
3
1 2 1 3

Sample Output 1

Copy
3
5
4
1

There are three subsequences with length 11 and 2 and 3.

There are five subsequences with length 21,1 and 1,2 and 1,3 and 2,1 and 2,3.

There are four subsequences with length 31,1,3 and 1,2,1 and 1,2,3 and 2,1,3.

There is one subsequence with length 41,2,1,3.


Sample Input 2

Copy
1
1 1

Sample Output 2

Copy
1
1

There is one subsequence with length 11.

There is one subsequence with length 21,1.


Sample Input 3

Copy
32
29 19 7 10 26 32 27 4 11 20 2 8 16 23 5 14 6 12 17 22 18 30 28 24 15 1 25 3 13 21 19 31 9

Sample Output 3

Copy
32
525
5453
40919
237336
1107568
4272048
13884156
38567100
92561040
193536720
354817320
573166440
818809200
37158313
166803103
166803103
37158313
818809200
573166440
354817320
193536720
92561040
38567100
13884156
4272048
1107568
237336
40920
5456
528
33
1

Be sure to print the numbers modulo 109+7.

题意:给N+1个数,范围在[1,n],且[1,n]每个数最少出现一次,问[1,n]长度的子序列各有多少种,结果模1e9+7。

思路:显然有一个数是重复出现的,那么需要处理下重复的。假如第i和i+3个数是一样的,此时计算子序列长度为x,在i前面和i+3后面选x-1个数就是重复的部分,减去它即可

,组合数计算用逆元。

# include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const LL mod = 1e9+7;
const LL maxn = 1e5+3;
LL inv[maxn+8]={1,1}, fi[maxn+8]={1,1}, fac[maxn+8]={1,1};
int vis[maxn+8]={0};
void init()
{
    for(int i=2; i<=maxn; ++i)
    {
        fac[i] = fac[i-1]*i%mod;
        inv[i] = (mod-mod/i)*inv[mod%i]%mod;
        fi[i] = fi[i-1]*inv[i]%mod;
    }
}

LL c(LL n, LL m)
{
    return fac[n]*fi[n-m]%mod*fi[m]%mod;
}
int main()
{
    init();
    int n, t, dis;
    scanf("%d",&n);
    for(int i=1; i<=n+1; ++i)
    {
        scanf("%d",&t);
        if(vis[t])
            dis = vis[t]+n-i;
        vis[t] = i;
    }
    for(int i=1; i<=n+1; ++i)
    {
        LL ans = c(n*1LL+1, i*1LL)%mod;
        if(dis >= i-1) ans = (ans-c(dis*1LL, i*1LL-1)+mod)%mod;
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值