AtCoder:Fennec VS. Snuke(dfs & 思维)

D - Fennec VS. Snuke


Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement

Fennec and Snuke are playing a board game.

On the board, there are N cells numbered 1 through N, and N1 roads, each connecting two cells. Cell ai is adjacent to Cell bi through the i-th road. Every cell can be reached from every other cell by repeatedly traveling to an adjacent cell. In terms of graph theory, the graph formed by the cells and the roads is a tree.

Initially, Cell 1 is painted black, and Cell N is painted white. The other cells are not yet colored. Fennec (who goes first) and Snuke (who goes second) alternately paint an uncolored cell. More specifically, each player performs the following action in her/his turn:

  • Fennec: selects an uncolored cell that is adjacent to a black cell, and paints it black.
  • Snuke: selects an uncolored cell that is adjacent to a white cell, and paints it white.

A player loses when she/he cannot paint a cell. Determine the winner of the game when Fennec and Snuke play optimally.

Constraints

  • 2N105
  • 1ai,biN
  • The given graph is a tree.

Input

Input is given from Standard Input in the following format:

N
a1 b1
:
aN1 bN1

Output

If Fennec wins, print Fennec; if Snuke wins, print Snuke.


Sample Input 1

Copy
7
3 6
1 2
3 1
7 4
5 7
1 4

Sample Output 1

Copy
Fennec

For example, if Fennec first paints Cell 2 black, she will win regardless of Snuke's moves.


Sample Input 2

Copy
4
1 4
4 2
2 3

Sample Output 2

Copy
Snuke
题意:一棵树由N个节点,1节点黑色,N节点白色,两个人轮流涂色,先手将黑色节点相邻一个无色节点涂成黑色,后手白色亦然,谁不能涂就输,问谁会赢。

思路:最优策略显然先往对方的路径涂过去,那么计算一下两色相遇时谁的子节点多即可。

# include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+3;
int cnt=0, id=0, Next[maxn],in[maxn],out[maxn];
int fa[maxn][20], len[maxn];
struct node
{
    int v, next;
}edge[maxn<<1];
void add_edge(int u, int v)
{
    edge[cnt] = {v, Next[u]};
    Next[u] = cnt++;
    edge[cnt] = {u, Next[v]};
    Next[v] = cnt++;
}
 
void dfs(int cur, int pre, int d)
{
    fa[cur][0] = pre;
    len[cur] = d;
    for(int i=1; i<20; ++i)
        fa[cur][i] = fa[fa[cur][i-1]][i-1];
    in[cur] = ++id;
    for(int i=Next[cur]; i!=-1; i=edge[i].next)
    {
        int v = edge[i].v;
        if(v == pre) continue;
        dfs(v, cur, d+1);
    }
    out[cur] = id;
}
int main()
{
    int n, a, b;
    scanf("%d",&n);
    memset(Next, -1, sizeof(Next));
    for(int i=1; i<n; ++i)
    {
        scanf("%d%d",&a,&b);
        add_edge(a, b);
    }
    dfs(1, 0, 0);
    int tmp=(len[n]-1)/2, now=n;
    for(int i=0; i<20; ++i)
        if(tmp>>i&1) now = fa[now][i];
    int bl = n-(out[now]-in[now]+1)-len[n]/2-1;
    int wh = out[now]-in[now]+1-tmp-1;
    if(len[n]&1)
    {
        if(bl <= wh) puts("Snuke");
        else puts("Fennec");
    }
    else
    {
        if(wh <= bl) puts("Fennec");
        else puts("Snuke");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这个正则表达式是用来匹配用户的设备类型的。它可以匹配到包括手机、平板、iPhone、iPad、Android、黑莓等各种设备类型。通过匹配用户的设备类型,可以实现不同设备的页面跳转和适配。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [js判断浏览器的环境(pc端,移动端,还是微信浏览器)](https://download.csdn.net/download/weixin_38714532/13205939)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [pc端||手机端判断。手机打开 自动跳转手机网站](https://blog.csdn.net/weixin_40292626/article/details/80309075)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [JavaScript-筑基(二十五)navigator对象(判断页面打开终端)、history对象](https://blog.csdn.net/weixin_59598992/article/details/122591894)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值