HDU 1711 Number Sequence(KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22070    Accepted Submission(s): 9437


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1

注意输出的时候要在待输出的位置加1,因为题目是默认是从1开始的,我们是从0开始输入的;

KMP 算法:

#include<stdio.h>
#include<string.h>
int a[1000010];
int b[1000010];
int next[1000010];
void makenext(int m)
{
	int j=0;
	next[0]=0;
	for(int i=1;i<m;i++)
	{
		while(j&&b[j]!=b[i])
		{
			j=next[j-1];
		}
		if(b[j]==b[i])
		{
			j++;
		}
		next[i]=j;
	}
}
void KMP(int n,int m)
{
	int j=0;
	for(int i=0;i<n;i++)
	{
		while(j&&a[i]!=b[j])
		{
			j=next[j-1];
		}
		if(a[i]==b[j])
		{
			j++;
		}
		if(j>=m)
		{
			printf("%d\n",i-m+1+1);
			return;
		}
	}
	printf("-1\n");
}
int main()
{
	int t,n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(int i=0;i<m;i++)
		{
			scanf("%d",&b[i]);
		}
		makenext(m);
		KMP(n,m);
	}
	return 0;
}

MP算法:
#include<stdio.h>
#include<string.h>
int n,m;
int a[1000010];
int b[10010];
int next[10010];//f[i]表示长度为i的子串前缀和后缀公共部分的最大长度;即最大公共长度;从1开始存的; 
void get()
{
	int i,j;
	next[0]=next[1]=0;
	for(int i=1;i<m;i++)
	{
		j=next[i];//j每次都表示next[i]的值即最大公共长度,同时也表示需要比较的下一个位置; 
		while( j && b[j]!=b[i])
		    j=next[j];//分割长度为j的字符串; 
		next[i+1]=b[j]==b[i]?j+1:0;
	}
}
void find()
{
	int i,j=0;
	for(int i=0;i<n;i++)
	{
		while( j && a[i]!=b[j])//如果j==0则j不再动,让i移动,知道找到一个i使a[i]==b[0]
		{                     //待比较的元素不匹配,移动j直到匹配; 
			j=next[j];
		}
		if(a[i]==b[j])//相等则j往后移; 
		j++;
		if(j>=m)//匹配成功; 
		{
			printf("%d\n",i-m+1+1);
			return;
		}
	}
	printf("-1\n");//循环结束后匹配不成功,输出-1; 
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(int i=0;i<m;i++)
		{
			scanf("%d",&b[i]);
		}
		get();
		find();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值