ACM ICPC 2017 Warmup Contest 6 G

G. Google is Feeling Lucky

Google is one of the most famous Internet search engines which hosts and develops a number of Internet-based services and products. On its search engine website, an interesting button “I‟m feeling lucky” attracts our eyes. This feature could allow the user skip the search result page and goes directly to the first ranked page.

Amazing! It saves a lot of time.The question is, when one types some keywords and presses “I‟m feeling lucky”button, which web page will appear? Google does a lot and comes up with excellent approaches to deal with it. In this simplified problem, let us just consider thatGoogle assigns every web page an integer-valued relevance. The most related page will be chosen. If there is a tie, all the pages with the highest relevance are possible to be chosen.

Your task is simple, given 1010 web pages and their relevance. Just pick out all the possible candidates which will be served to the user when “I‟m feeling lucky”.

Input

The input contains multiple test cases. The number of test cases T is in the first line of the input file.

For each test case, there are 1010 lines, describing the web page and the relevance.

Each line contains a character string without any blank characters denoting the URL of this web page and an integer Vi denoting the relevance of this web page. The length of the URL is between 11 and 100100 inclusively. (1 \le Vi \le 100)(1≤Vi≤100)

Output

For each test case, output several lines which are the URLs of the web pages which are possible to be chosen. The order of the URLs is the same as the input.

Please look at the sample output for further information of output format.

样例输入

2
www.youtube.com 1
www.google.com 2
www.google.com.hk 3
www.alibaba.com 10
www.taobao.com 5
www.bad.com 10
www.good.com 7
www.fudan.edu.cn 8
www.university.edu.cn 9
acm.university.edu.cn 10
www.youtube.com 1
www.google.com 2
www.google.com.hk 3
www.alibaba.com 11
www.taobao.com 5
www.bad.com 10
www.good.com 7
www.fudan.edu.cn 8
acm.university.edu.cn 9
acm.university.edu.cn 10
样例输出

Case #1:
www.alibaba.com
www.bad.com
acm.university.edu.cn
Case #2:
www.alibaba.com

题目的意思是找出相关度高的网站,然后按先后顺序输出来。可以直接开个结构体,然后排序。

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
int pos[100], num[100];
struct website
{
    char url[101];
    int rel;
    int id;
}web[20];
bool cmp(const website &web1, const website &web2)
{
    if (web1.rel > web2.rel)
        return true;
    else if (web1.rel == web2.rel)
    {
        if (web1.id < web2.id) return true;
    }
        return false;
}
int main()
{
    int T;
    cin >> T;
    while (T--) {

        for (int i = 0; i < 10; i++)
        {
            cin >> web[i].url >> web[i].rel;
            web[i].id = i;
        }
        web[10].rel = 0;
        sort(web, web + 10, cmp);
        cout << "Case #" << n++ << ":\n";
        int flag; int j = 0;
        flag = web[j].rel;
        while (flag == web[j].rel)
        {
            cout << web[j].url << endl;
            flag = web[j].rel;
            j++;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值