Dividing (HDU 1059) —— 多重背包

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16994    Accepted Submission(s): 4753


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source
 
题意:给你6个数据,分别是价值为1、2、3、4、5、6的6块大理石的数量,求能否把它分成2部分价值相同的大理石(不能分割);

刚开始我又想暴力,结果想得太简单了。最后还是得用dp。多重背包。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[45000];

void CompletePack(int v, int w, int m)
{
    for(int j=v; j<=m; j++)
        dp[j] = max(dp[j], dp[j-v]+w); //用库里的函数比我自己定义的速度要快%>_<%
}
void ZeroOnePack(int v, int w, int m)
{
    for(int j=m; j>=v; j--)
        dp[j] = max(dp[j], dp[j-v]+w);
}
void MultiPack(int v, int w, int c, int m) 
{
    if(c*v >= m) CompletePack(v,w,m);
    else
    {
        int k = 1;
        while(k < c) //二进制优化
        {
            ZeroOnePack(k*v,k*w,m);
            c -= k;  k <<= 1;
        }
        ZeroOnePack(c*v,c*w,m);
    }
}

int main()
{
    int i, t = 1, c[10];

    while(~scanf("%d%d%d%d%d%d", &c[1],&c[2],&c[3],&c[4],&c[5],&c[6]))
    {
        if(c[1]+c[2]+c[3]+c[4]+c[5]+c[6] == 0) break;
        printf("Collection #%d:\n", t++); //注意这个输出不要放后面
        int m = 0;
        for(i=1; i<=6; i++) m += i*c[i]; //m求总和
        if(m & 1) //当总数为奇时不能分割
        {
            puts("Can't be divided.\n");
            continue;
        }
        m >>= 1; //看是否能达到一半
        memset(dp, 0, sizeof(dp));
        for(i=1; i<=6; i++)
            MultiPack(i,i,c[i],m); //用多重背包,体积和重量都是i
        if(dp[m] == m) puts("Can be divided.\n"); //如果最大能达到一半,则可分
        else puts("Can't be divided.\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值