poj 2406 Power Strings KMP应用

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 27694 Accepted: 11600

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

如果len%(len-next[len-1])==0,则 字符串中必存在最小循环节,且循环次数 即为 len/(len-next[len-1])
证明:
必要性:因为字符串中存在最小循环节 (设长度为k),next[len-1]=len-k,所以len%(lennext[len-1])==0; 
充分性:令k1=len-next[len-1],由于k1整除len, 所以可以相应的把len划分为n片区域 (n=len/(k1)),从小到大依次表示为 • t1,t2...tn;由next数组的定义可知, t1=t2,t2=t3,...t(n-1)=tn,且相应的片区域即为最 小,所以循环次数也为len/(len-next[len-1]);
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int nMax=1000005;
const int mMax=1000005;
char text[mMax],pat[nMax];
int lent,lenp,next[nMax];
void get_next()
{
    int i,j=0;
    next[0]=-1;
    for(i=1; i<lenp; i++)
    {
        j=next[i-1];
        while(j&&pat[j]!=pat[i])
            j=next[j-1];
        if(pat[j]==pat[i])
        {
            next[i]=j+1;
        }
        else next[i]=0;
    }
}
//int KMP()
//{
//    int ans=0,i=0,j=-1;
//    get_next();
//    for(i=0; i<lent; i++)
//    {
//        while(j!=-1&&pat[j+1]!=text[i])
//        {
//            j=next[j];
//        }
//        if(pat[j+1]==text[i])j=j+1;
//        if(j==lenp-1)ans++;  //找到一个匹配
//    }
//    return ans;
//}
int main()
{
    int t;
//    scanf("%d",&t);
    while(scanf("%s",pat)&&pat[0]!='.')
    {

        lenp=strlen(pat);
//        lent=strlen(text);
//        printf("%d\n",KMP());
        get_next();
//for(int i=1;i<5;i++)
//    cout<<next[i]<< " ";
        if(lenp%(lenp-next[lenp-1])==0)
        {
            printf("%d\n",lenp/(lenp-next[lenp-1]));
        }
        else
            printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值