poj 2115 C Looooops 扩展欧几里德算法

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15305 Accepted: 3901

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

题意:对于C的for(i=A ; i!=B ;i +=C)循环语句,问在k位存储系统中循环几次才会结束。若在有限次内结束,则输出循环次数。
令a=C
b=B-A
n=2^k
那么原模线性方程变形为:
ax=b (mod n)
该方程有解的充要条件为 gcd(a,n) | b ,即 b% gcd(a,n)==0
令d=gcd(a,n)
有该方程的 最小整数解为 x = e (mod n/d)
其中e = [x0 mod(n/d) + n/d] mod (n/d) ,x0为方程的最小解
那么原题就是要计算b% gcd(a,n)是否为0,若为0则计算最小整数解,否则输出FOREVER
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

long long A,B,C,K;

long long ex_gcd(long long a,long long &x,long long b,long long &y)
{
    if(b==0)
    {
        x = 1;
        y = 0;
        return a;
    }
    long long d = ex_gcd(b,x,a%b,y);
    long long tmp = x;
    x = y;
    y = tmp - (a/b)*y;
    return d;
}

int main()
{
    long long mod, X, Y;
    while(cin>>A>>B>>C>>K)
    {
        if(A==0&&B==0&&C==0&&K==0)
            break;
        mod = ((long long)1<<K);
        long long d = ex_gcd(C, X, mod, Y);
        long long T = B-A;
        if(T%d!=0)
            puts("FOREVER");
        else
        {
            X = X*T/d;
            long long ans = (X%mod+mod)%mod;
            ans = ans%(mod/d);
            cout<<ans<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值