poj 1200 Crazy Search 字符串hash

Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20551 Accepted: 5809

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

题意:
判断nc个字符出现的字符串中,长度为n的子串的个数。
Rabin-Karp算法
如果字符串中可能出现的字符有k个,则可以将字符串对应到k进制数。
#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
#define N 16000000
string str;
bool hash[N];
int cha[500];
int main()
{
    int k=0;
    int n,nc,ans=0,sum;
    scanf("%d%d",&n,&nc);
    cin>>str;
    for(int i=0;i<str.length();i++)
    {
        if(cha[str[i]]==0)
            cha[str[i]]=++k;//为出现的字符安排权值
        if(k==nc) break;
    }
    for(int i=0;i<str.length()-n+1;i++)
    {
        sum=0;
        for(int j=i;j<i+n;j++)
        {
            sum=(sum*nc+cha[str[j]])%N;//计算出键值
        }
        if(!hash[sum])//hash表中未出现的子串计数
        {
            hash[sum]=true;
            ans++;
        }
    }
    printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值