POJ - 1200 A - crazy search

9 篇文章 0 订阅

A - Crazy Search

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4

daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

 

 

 

#include <stdio.h>

#include <string.h>

#include <cstring>

#define maxn 16000001

int n,nc;

int hash[maxn],num[500];//子串是否出现过.字符串中每个字符的值

char a[maxn];//保存字符串

int main()

{

    while(scanf("%d%d%s",&n,&nc,a)!=EOF)

    {

        memset(num,0,sizeof(num));

        memset(hash,0,sizeof(hash));

        int i,j,l;

        int t=1;//t值用来作为每个字符的哈希值

        l=strlen(a);

        for(i=1;i<l&&t<nc;i++)

        {

            if(num[a[i]]==0)

                num[a[i]]=t++;

        }

        int ans=0;

        for(i=0;i<=l-n;i++)

        {

            int sum=0;

            for(j=0;j<n;j++)

            {

                sum=sum*nc+num[a[i+j]];//特殊的赋值方法、转换成一个特殊的数

                sum=sum%16000000;

            }

            if(hash[sum]==0)

            {

                ans++;

                hash[sum]=1;

            }

        }

        printf("%d\n",ans);

    }

    return 0;

}

 

 

题目大意,输入一个子串长度和一个字符种数,然后判断该字符串中的连续子串的个数,重复的不参与重复计算。

题目思路,对每个子串进行hash就可以了。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值