POJ --- 1200 Crazy Search

POJ  1200  Crazy  Search


Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.     

 Input

    The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

 Output

    The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

 Sample Input

  3 4
  daababac

 Sample Output

  5

   (ps:Huge input,scanf is recommended.)



     题意:给你一个字符串,字符串里只有 NC 种字符,给你一个N ,让你在给定的字符串里找到连续的N 长度的字符串有多少种。

   思路:找有多少种其实只要遍历一遍就行,重点是如何判断是否在前面有重复的字符串,那么 hash值就出来了,我们可以直接先把给定的字符串每种类型给定一个数字, 然后在遍历的时候记录已经找过的字符串组成的数字。这样就可以存下已经有的字符串类型。 


   代码:



#pragma comment(linker, "/STACK:1024000000,1024000000")
//#include <bits/stdc++.h>
#include<string>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#define maxn 16000000+10
#define INF 0x3f3f3f3f
using namespace std;

bool hash[maxn];
int num[300];
char A[maxn];
int main()
{
    int n,base;
    while(scanf("%d%d",&n,&base)!=EOF)
    {
        memset(num,0,sizeof num);
        memset(hash,0,sizeof hash);
        scanf("%s",A);
        int len=strlen(A);
        int cnt=0;
        for(int i=0;i<len;i++)
        {
            if(!num[A[i]])  num[A[i]]=cnt++;
        }
        int ans=0;
        for(int i=0;i<=len-n;i++)
        {
            int sum=0;
            for(int j=0;j<n;j++)
            {
                sum=sum*cnt+num[A[j+i]];
            }
            if(!hash[sum])
            {
                ans++;
                hash[sum]=1;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值