wikioi 1083 Cantor表

题目描述 Description

现代数学的著名证明之一是Georg Cantor证明了有理数是可枚举的。他是用下面这一张表来证明这一命题的: 1/1 1/2 1/3 1/4 1/5 … 2/1 2/2 2/3 2/4 … 3/1 3/2 3/3 … 4/1 4/2 … 5/1 … … 我们以Z字形给上表的每一项编号。第一项是1/1,然后是1/2,2/1,3/1,2/2,…

输入描述 Input Description

整数N(1≤N≤10000000)

输出描述 Output Description

表中的第N项

样例输入 Sample Input

7

样例输出 Sample Output

1/4

感觉这道题是很简单了,照着题意写就行了,

/*
作者:t_rex
题目:p1083 Cantor表
*/

#include <iostream>
using namespace std;
void cantor(int n){
  int i = 1, j = 1, cnt = 1, plus = 0;
  while(true){
    plus = 0;
    while(plus < 1 && cnt != n)
      j++, cnt++, plus++;
    while(cnt != n && j > 1)
      i++, j--, cnt++;
    plus = 0;
    while(plus < 1 && cnt != n)
      i++, cnt++, plus++;
    while(cnt != n && i > 1)
      i--, j++, cnt++;
    if(cnt == n) break;
  }
  cout<<i<<"/"<<j;
}
int main()
{
    int n;
    cin>>n;
    cantor(n);
    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值