Problem A


Problem A

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 504   Accepted Submission(s) : 99
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

请统计给定某个范围[L,R](1<=L<R<=10000)的所有整数中,出现数字M(1<=M<=9)的总次数。

Input

一行输入三个整数L、R、M,中间以空格隔开。(有多个测试用例)

Output

输出[L,R]之间所有整数中出现M的次数总和。

Sample Input

2 22 2

Sample Output

6

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int l,r,m;
    int a[10];
    while(~scanf("%d %d %d",&l,&r,&m))
    {
        memset(a,0,sizeof(a));
        for(int i=l;i<=r;i++)
        {
            int j=i;
            while(j)
            {
                int x=j%10;
                a[x]++;
                j=j/10;
            }
        }
        printf("%d\n",a[m]);
    }
    return 0;
}


题目描述 定义一个Point类,表示平面上的点,具有x和y两个坐标成员变量,以及设置和获取坐标的方法。还要实现计算两点之间距离的方法。 输入描述 无输入。 输出描述 无输出。 样例 无样例。 提示 要求定义Point类,具有如下成员: 成员变量: double x:表示点的横坐标。 double y:表示点的纵坐标。 成员函数: Point():构造函数,将x和y初始值为0.0。 Point(double x, double y):构造函数,将x和y初始值为参数值。 void setX(double x):设置点的横坐标。 double getX():获取点的横坐标。 void setY(double y):设置点的纵坐标。 double getY():获取点的纵坐标。 double distance(Point another):计算当前点与另外一个点之间的距离,返回距离值。 注意:在类的实现中,要包含头文件cmath,使用其中的sqrt函数求平方根。 C++ 代码 ```cpp #include <iostream> #include <cmath> using namespace std; class Point { private: double x, y; public: Point() : x(0.0), y(0.0) {} Point(double x, double y) : x(x), y(y) {} void setX(double x) { this->x = x; } double getX() { return x; } void setY(double y) { this->y = y; } double getY() { return y; } double distance(Point another) { double dx = x - another.x; double dy = y - another.y; return sqrt(dx * dx + dy * dy); } }; int main() { Point p1, p2(3.0, 4.0); p1.setX(1.0); p1.setY(2.0); cout << "p1: (" << p1.getX() << ", " << p1.getY() << ")" << endl; cout << "p2: (" << p2.getX() << ", " << p2.getY() << ")" << endl; cout << "distance between p1 and p2: " << p1.distance(p2) << endl; return 0; } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值