POJ - 3259 Wormholes (图论/floyd判断负圈)

问题描述
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

分析:

代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 500+10; 
const int maxe = 5200+10;
struct edge{
    int from, to, cost;
}es[maxe];
int F;
int V,E;
int d[maxn];

/*判断是否有负圈*/
bool find_negative_loop()
{
    memset(d, 0, sizeof(d));
    for(int i=0; i<V; i++)
    {
        for(int j=0; j<E; j++)
        {
            edge e = es[j];
            if(d[e.to] > d[e.from] + e.cost)
            {
                d[e.to] = d[e.from] + e.cost;
                if(i == V-1) return true;
            }
        }
    }
    return false;
}

int main()
{
    scanf("%d",&F);
    while(F--)
    {
        int N,M,W;
        scanf("%d%d%d",&N,&M,&W);
        V = N;
        E = 0; 
        int s,e,t;
        for(int i=0; i<M; i++)
        {
            scanf("%d%d%d",&s,&e,&t);
            es[E].from = s;
            es[E].to = e;
            es[E].cost = t;
            E++;
            es[E].to = s;
            es[E].from = e;
            es[E].cost = t;
            E++;
        }   
        for(int i=0; i<W; i++)
        {
            scanf("%d%d%d",&s,&e,&t);
            es[E].from = s;
            es[E].to = e;
            es[E].cost = -t;
            E++;
        }
        if(find_negative_loop()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值