POJ-3087 Shuffle'm Up(DFS)

5 篇文章 0 订阅

问题描述
A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:
这里写图片描述
The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output
Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

分析:
题目大意就是有两堆木块S1和S2垒起来,每一堆C块木块,然后再给一堆2*C的木块S12,判断经过一系列对于S1和S2这两堆木块的操作是否能够和S12这一堆木块相等,如果有输出操作次数,如果没有输出-1,很明显的一个深搜,按照题目给定的操作进行DFS就行。

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1000+10;
int C;
char s1[maxn], s2[maxn], s12[2*maxn], s[2*maxn], s13[2*maxn];
int cnt;

void DFS(char *st, int &cnt)
{
    if(strcmp(st, s) == 0)
    {
        return;
    }
    /*分割*/
    for(int i=0; i<C; i++)
    {
        s1[i] = st[i];
    }
    for(int i=C; i<2*C; i++)
    {
        s2[i-C] = st[i];
    }

    /*重组*/ 
    for(int i=0; i<C; i++)
    {
        s12[2*i] = s2[i];
        s12[2*i+1] = s1[i];
    }
    if(strcmp(s12, s13) == 0)
    {
        cnt = -1;
        return;
    }
    cnt++;
    DFS(s12,cnt);
}
int main()
{
    int T;
    int kase = 0;
    scanf("%d",&T);
    while(T--)
    {
        //输入数据
        scanf("%d",&C);
        getchar();
        for(int i=0; i<C; i++)
        {
            scanf("%c", &s1[i]);
        }
        getchar();
        for(int i=0; i<C; i++)
        {
            scanf("%c", &s2[i]);
        }
        getchar();
        for(int i=0; i<2*C; i++)
        {
            scanf("%c", &s[i]);
        }
        for(int i=0; i<C; i++)
        {
            s12[2*i] = s2[i];
            s12[2*i+1] = s1[i];
        }       
        strcpy(s13,s12); 
        cnt = 1;
        DFS(s12, cnt);
        printf("%d %d\n",++kase,cnt); 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值