PAT甲级 1025 Ranking

A1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意:
有n个考场,每个考场有若干数量的学生,输入每个考场中考生的编号和分数,要求算排名。输出所有考生的编号、排名、考场号、考场内排名。

思路:
1.全局变量num计总考生数

2.按考场读入考生信息,先对每个考场排序

3.对所有考生排序,同时输出总排名和考生信息

注意点:每读入一个考生,num自增,对同一考场考生,数量为[num-k,num)

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct student{
    char id[15];
    int score;
    int location;
    int loc_rank;
}stu[30010];
bool cmp(student a,student b){
    return a.score!=b.score?a.score>b.score:strcmp(a.id,b.id)<0;
}
int main()
{
    int n,num=0,k=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&k);
        for(int j=0;j<k;j++){
            scanf("%s %d",stu[num].id,&stu[num].score);
            stu[num].location=i;
            num++;
        }
        sort(stu+num-k,stu+num,cmp);
        stu[num-k].loc_rank=1;

        for(int j=1;j<k;j++){
            if(stu[num-k+j].score==stu[num-k+j-1].score)
                stu[num-k+j].loc_rank=stu[num-k+j-1].loc_rank;
            else
                stu[num-k+j].loc_rank=j+1;
        }
    }
    printf("%d\n",num);
    sort(stu,stu+num,cmp);
    int r=1;
    printf("%s %d %d %d\n",stu[0].id,r,stu[0].location,stu[0].loc_rank);
    for(int i=1;i<num;i++){
        if(stu[i].score==stu[i-1].score)
                printf("%s %d %d %d\n",stu[i].id,r,stu[i].location,stu[i].loc_rank);
            else{
                printf("%s %d %d %d\n",stu[i].id,i+1,stu[i].location,stu[i].loc_rank);
                r=i+1;
            }
    }

    return 0;
    
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值