PAT甲级 1012 Best Rank

1012 The Best Rank (25 分)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:
先读入n个考生的3门分数,并可以算出平均分。然后分别对这四个分数从高到低排序,为每位考生算出4个排名。再有m次查询,对于每一个学生id,输出当前id学生的最好的排名和它对应的分数,如果名次相同,按照A>C>M>E的顺序输出。如果当前id不存在,输出N/A

思路:
1.由于有优先级A>C>M>E,读入A,C,M,E分数时,设置grade[4]数组按3,2,1,0顺序读入数组,方便成绩一样时进行比较
2.cmp函数仅比较两个学生的分数
3.设置全局数组Rank[10000000][4]进行排名,方便直接用学号进行查找,也方便有不存在学号时的输出

注意:
1.排名并列应该1、1、3、4、5,而不是1、1、2、3、4
2.平均分A可以直接把三个数相加,不用除,以免考虑四舍五入
3.始终用下标k来代表A、C、M、E
4.k和排名数组Rank[10000000][4]要是全局变量

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct student{
    int id;
    int grade[4];
}stu[2010];
int k;
int Rank[10000000][4]={0};
bool cmp(student a,student b){
    return a.grade[k]>b.grade[k];

}
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;i++){
        scanf("%d %d %d %d",&stu[i].id,&stu[i].grade[2],&stu[i].grade[1],&stu[i].grade[0]);
        stu[i].grade[3]=stu[i].grade[0]+stu[i].grade[1]+stu[i].grade[2];
    }
    for(k=0;k<4;k++){
        sort(stu,stu+n,cmp);
        Rank[stu[0].id][k]=1;
        for(int i=1;i<n;i++){
            if(stu[i].grade[k]==stu[i-1].grade[k])
                Rank[stu[i].id][k]=Rank[stu[i-1].id][k];
            else Rank[stu[i].id][k]=i+1;
        }
    }
    char kemu[4]={'E','M','C','A'};
    int x;
    for(int i=0;i<m;i++){
        scanf("%d",&x);
        if(Rank[x][0]==0) printf("N/A\n");
        else{
            int min=3;
            for(int j=3;j>=0;j--){
                if(Rank[x][j]<Rank[x][min]) min=j;
            }
        printf("%d %c\n",Rank[x][min],kemu[min]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值