PAT 甲级 1012 The Best Rank

PAT 甲级 1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
结尾无空行

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
结尾无空行
题意描述:

每个学生有四个成绩,按照A>C>M>E的优先级顺序输出成绩排名最高的排名以及科目(包括平均分)

解题思路:

每个科目的成绩都是独立的,因此先分别对四种成绩按照降序排序,然后对于每一个查询id,采用哈希表映射到该学生所在的下标,然后分别针对四种成绩,查询该学生的成绩排名,取最小的排名并输出。

难度评测:Middle Hard(思路比较清晰,但代码实现可能比较绕)
AC代码实现:
#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
const int N = 2e3+5;
struct Student {
	int id, score[4];
}stu[N];
int a[4][N];

int main() {
	unordered_map<int, int>mp;
	int n, m, id;
	cin >> n >> m;
	for(int i = 1; i <= n; i++) {
		cin >> id >> a[1][i] >> a[2][i] >> a[3][i];
		mp[id] = i;
		a[0][i] = (a[1][i] + a[2][i] + a[3][i]) / 3;
		stu[i].id = id;
		for(int j = 0; j < 4; j++)
			stu[i].score[j] = a[j][i];
	}
	for(int i = 0; i < 4; i++) 
		sort(a[i] + 1, a[i] + n + 1, greater<int>());
	while(m--) {
		cin >> id;
		if(!mp[id]) {
			puts("N/A");
			continue;
		}
		char type[] = {'A', 'C', 'M', 'E'};
		int r[4], rmn = INF, ind;
		for(int i = 0; i < 4; i++) {
			for(int j = 1; j <= n; j++) {
				if(stu[mp[id]].score[i] == a[i][j]) {
					r[i] = j;
					break;
				}
			}
			if(r[i] < rmn) {
				rmn = r[i];
				ind = i;
			}
		}
		printf("%d %c\n", rmn, type[ind]);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值