uva757

John is going on a fishing trip. He has h hours available ( $1 \leŸ h \leŸ 16$), and there are n lakes in the area ( $2 \leŸ n \leŸ 25$) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each $i = 1, \dots, n- 1$, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti ( $0 < t_i \leŸ 192$). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4.


To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi ( $f_i \ge– 0$), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di ( $d_i \ge– 0$). If the number of fish expected to be caught in an interval is less than or equal to di, there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.


Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input 

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying f i ( $1 \leŸ i \leŸ n$), then a line of n integers d i ( $1 \leŸ i \leŸ n$), and finally, a line of n - 1 integers t i ( $1 \leŸ i Ÿ\le n - 1$). Input is terminated by a case in which n = 0.

Output 

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input 

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0

Sample Output 

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724



我觉得这题贪心还是挺不错的

没想到怎么做

听了某同学的讲解才懂得怎么做

因为是单向的

所以依次枚举去了几个池塘

把总时间扣去转移的时间

剩下的钓鱼时间是固定的

就是看怎么分配时间给各个池塘

用一个while(hcnt < htemp)

在while循环里面比较当前在哪个池塘钓的鱼多


变量比较多, 调试了很久

有WA了好多发,看了题解才意识到

不一定会有答案

这种时候就把所有时间都给第一个池塘


#include <cstdio>
#include <cstring>
#define N 1010
int f[N], d[N], dt[N], tans[N], ttemp[N], ftemp[N];

int main(){
	int n, h;
	int fflag = 1;
	while (scanf("%d", &n) && n) {
		memset(tans, 0, sizeof(tans));
		scanf("%d", &h);
		h = h * 60;
		for (int i = 0; i < n; i++)
			scanf("%d", &f[i]);
		for (int i = 0; i < n; i++) 
			scanf("%d", &d[i]);
		dt[0] = 0;
		for (int i = 1; i < n; i++) {
			scanf("%d", &dt[i]);
			dt[i] = dt[i] * 5;
		}
		int ans = 0;
		for (int i = 0; i < n; i++) {
			for (int j = 0; j < n; j++)
				ftemp[j] = f[j];
			int htemp = h;
			for (int j = 0; j <= i; j++)
				htemp -= dt[j];
			if (htemp <= 0)
				break;
			int hcnt = 0;
			int ntemp = 0;
			memset(ttemp, 0, sizeof(ttemp));
			while (hcnt < htemp) {
				int mmax = 0;
				int mark = 0;
				int flag = 0;
				for (int j = 0; j <= i; j++) {
					if (ftemp[j] > mmax) {
						mmax = ftemp[j];
						mark = j;
						flag = 1;
					}
				}
				if (flag) {
					hcnt += 5;
					ntemp += mmax;
					ftemp[mark] -= d[mark];
					ttemp[mark] += 5;
				}
				else {
					hcnt += 5;
					ttemp[0] += 5;
				}
			}
			if (ntemp > ans) {
				ans = ntemp;
				for (int j = 0; j <= i; j++)
					tans[j] = ttemp[j];
			}
		}
		if (fflag)
			fflag = 0;
		else
			printf("\n");
		if (!ans)
			tans[0] = h;
		for (int i = 0; i < n; i++) {
			if (i == 0)
				printf("%d", tans[i]);
			else
				printf(", %d", tans[i]);
		}
		printf("\nNumber of fish expected: %d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值