HDU 5804 Price List

Problem Description
There are n shops numbered with successive integers from 1 to n in Byteland. Every shop sells only one kind of goods, and the price of the i-th shop's goods is vi.

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.


Input
The first line of the input contains an integer T (1≤T≤10), denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m (1≤n,m≤100000), denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains n integers v1,v2,...,vn (1≤vi≤100000), denoting the price of the i-th shop's goods.

Each of the next m lines contains an integer q (0≤q≤1018), denoting each number on Byteasar's account book.


Output
For each test case, print a line with m characters. If the i-th number is sure to be strictly larger than the actual value, then the i-th character should be '1'. Otherwise, it should be '0'.


Sample Input
1
3 3
2 5 4
1
7
10000


Sample Output
001


Source

BestCoder Round #86

题意:

共有n个商店,每个商店只卖一种商品,并标有价格,Byteasar每天都会买东西,但是商店中的商品不一定买,每天他都会记录所买商品的总价,

给出m条记录,对于每条记录,如果记录的总价一定大于实际的价格,输出“1”,否则输出“0”,

思路:

只需判断记录的总价是否大于所有商品的总价,,,


以下AC代码:


#include<stdio.h>
int v[100005];
long long sum;
int flag[100005];
int main()
{
    int t,n,m;
    int i;
    long long q;
    scanf("%d",&t);
    while(t--)
        {
            sum=0;
            scanf("%d%d",&n,&m);
            for(i=0;i<n;i++)
            {
                scanf("%d",&v[i]);
                sum+=v[i];
            }
              for(i=0;i<m;i++)
              {
                  scanf("%I64d",&q);
                  if(q>sum)
                    flag[i]=1;
                  else
                    flag[i]=0;
              }
            for(i=0;i<m;i++)
                printf("%d",flag[i]);
            printf("\n");
        }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值