HDU 5804 Price List(水题)

16 篇文章 0 订阅

Price List

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 143 Accepted Submission(s): 106

Problem Description
There are n shops numbered with successive integers from 1 to n in Byteland. Every shop sells only one kind of goods, and the price of the i-th shop’s goods is vi.

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar’s poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn’t used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.

Input
The first line of the input contains an integer T (1≤T≤10), denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m (1≤n,m≤100000), denoting the number of shops and the number of records on Byteasar’s account book.

The second line of the input contains n integers v1,v2,…,vn (1≤vi≤100000), denoting the price of the i-th shop’s goods.

Each of the next m lines contains an integer q (0≤q≤1018), denoting each number on Byteasar’s account book.

Output
For each test case, print a line with m characters. If the i-th number is sure to be strictly larger than the actual value, then the i-th character should be ‘1’. Otherwise, it should be ‘0’.

Sample Input
1
3 3
2 5 4
1
7
10000

Sample Output
001

Source
BestCoder Round #86

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
#define ll long long

int main()
{
    int n,m;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        ll sum=0;
        ll x,y;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d",&x);
            sum+=x;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%I64d",&y);
            if(y>sum)
            {
                printf("1");
            }
            else
            {
                printf("0");
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值