HDU 3579 Hello Kiki 解题报告(中国剩余定理 非互质)

96 篇文章 0 订阅
6 篇文章 0 订阅

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1835    Accepted Submission(s): 649


Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
 

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
 

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
 

Sample Input
  
  
2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76
 

Sample Output
  
  
Case 1: 341 Case 2: 5996
 

Author
digiter (Special Thanks echo)
 

    解题报告:在刘汝佳老师的书上学了中国剩余定理,不过限制是给定的m[]都是两两互质的。本题中的除数就不是互质的,所以我们要换一种方法:合并模方程。
    关于合并的证明,我在这里看到的: http://yzmduncan.iteye.com/blog/1323599/。建议大家自己证明一下。
    另外,题目有个坑爹的地方,输出正数。如果结果是0,就加上最后的模数。
    本人代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100;
int mi[maxn];
int ai[maxn];
int cas=1;

void gcd(int a,int b,int &d,int &x,int &y)
{
    if(b==0)
    {
        d=a;
        x=1;
        y=0;
    }
    else
    {
        gcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}

int china_2(int n,int m[],int a[])
{
    int aa = a[0];
    int mm = m[0];

    for(int i=1;i<n;i++)
    {
        int ta=((a[i]-aa)%m[i]+m[i])%m[i];

        int d,x,y;
        gcd(mm,m[i],d,x,y);
        if(ta%d) return -1;

        int newM = mm/d*m[i];
        aa = ((long long)ta/d*x*mm%newM+aa)%newM;
        mm = newM;
    }
    aa = (aa+mm)%mm;
    if(aa==0) aa=mm;
    return aa;
}

void work()
{
    int n;
    scanf("%d",&n);

    for(int i=0;i<n;i++)
        scanf("%d", mi+i);
    for(int i=0;i<n;i++)
        scanf("%d", ai+i);

    int ans = china_2(n,mi,ai);
    printf("Case %d: %d\n", cas++, ans);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
        work();
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值