hdu - 3579 - Hello Kiki - (不互质的中国剩余定理)

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again... 
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note. 
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
Input
The first line is T indicating the number of test cases. 
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line. 
All numbers in the input and output are integers. 
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1. 
Sample Input
2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76
Sample Output
Case 1: 341
Case 2: 5996

因为中国剩余定理中要求m1~mi两两互素,但此题中给出的M1~Mi未说明是两两互素,这里的方法是可以作为此类题目的模板的,

参考:http://blog.csdn.net/u010579068/article/details/45422941

http://blog.csdn.net/v5zsq/article/details/48006101

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;

int n;
ll M[10],A[10];

void ex_gcd(ll a,ll b,ll &d,ll&x,ll&y)
{
    if(!b)
    {
        d=a;
        x=1;
        y=0;
    }else{
        ex_gcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
ll CRT()
{
    ll dm,i,a,b,x,y,d;
    ll c,c1,c2;
    a=M[0];
    c1=A[0];
    for(i=1;i<n;i++)
    {
        b=M[i];
        c2=A[i];
        ex_gcd(a,b,d,x,y);
        c=c2-c1;
        if(c%d)
            return -1;
        dm=b/d;
        x=((x*(c/d))%dm+dm)%dm;
        c1=a*x+c1;
        a=a*dm;
    }
    if(c1==0)
    {
        c1=1;
        for(i=0;i<n;i++)
            c1=c1*M[i]/gcd(c1,M[i]);
    }
    return c1;
}

int main()
{
    int i,T,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);

        for(i=0;i<n;i++)
            scanf("%lld",&M[i]);
        for(i=0;i<n;i++)
            scanf("%lld",&A[i]);

        printf("Case %d: %lld\n",++cas,CRT());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值