HDU3579 Hello Kiki 中国剩余定理

5 篇文章 0 订阅
5 篇文章 0 订阅

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6297 Accepted Submission(s): 2404

Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing “门前大桥下游过一群鸭,快来快来 数一数,二四六七八”. And then the cashier put the counted coins back morosely and count again…
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki’s father found her note and he wanted to know how much coins Kiki was counting.

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

Sample Input
2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76

Sample Output
Case 1: 341
Case 2: 5996

问题连接

问题描述

有一个喜欢以不同方式数数的女孩,现在她用N种方式数X个(未知)硬币,Mi个硬币为一组数,剩下Ai个,i为1到N。问这些硬币最少有多少个,如果存在答案输出X,否则输出-1。

问题分析

明显是用中国剩余定理求解,而且是模板题。由于Mi两两不一定互质,所以不能用原版的中国剩余定理求解,要用扩展版的。有一点要注意的是,如果取模后结果为0,要输出Mi(i从1到n)的最小公倍数。

代码如下

#include<iostream>
using namespace std;
typedef long long ll;
const int N=10; 

int n;
ll m[N],a[N];

ll exgcd(ll a,ll b,ll &x,ll &y){
	if(b==0){
		x=1;
		y=0;
		return a;
	}
	ll ans,x1,y1;
	ans=exgcd(b,a%b,x1,y1);
	x=y1;
	y=x1-(a/b)*y1;
	return ans;
}

ll CRT(){
	ll M,R,x,y,g,c;
	R=a[0];
	M=m[0];
	for(int i=1;i<n;i++){
		g=exgcd(M,m[i],x,y);
		c=a[i]-R;
		if(c%g) return -1;
		ll t=m[i]/g;
		x=(c/g*x)%t;
		R=M*x+R;
		M=M/g*m[i];
		R%=M;
	}
	R=(R+M)%M;
	if(R==0) R=M;
	return R;
}

int main(){
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	int time;
	cin>>time;
	for(int t=1;t<=time;t++){
		cin>>n;
		for(int i=0;i<n;i++) cin>>m[i];
		for(int i=0;i<n;i++) cin>>a[i];
		cout<<"Case "<<t<<": "<<CRT()<<endl;
	}
	return 0;
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值