Uva 10883 - Supermean 解题报告(对数)

96 篇文章 0 订阅
Problem F
Supermean
Time Limit: 2 second

"I have not failed. I've just found 10,000 ways that won't work."

Thomas Edison

Do you know how to compute the mean (or average) of n numbers? Well, that's not good enough for me. I want the supermean! "What's a supermean," you ask? I'll tell you. List the n given numbers in non-decreasing order. Now compute the average of each pair of adjacent numbers. This will give you  n - 1  numbers listed in non-decreasing order. Repeat this process on the new list of numbers until you are left with just one number - the supermean. I tried writing a program to do this, but it's too slow. :-( Can you help me?

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing n(0<n<=50000). The next line will contain the n input numbers, each one between -1000 and 1000, in non-decreasing order.

Output
For each test case, output one line containing "Case #x:" followed by the supermean, rounded to 3 fractional digits.

Sample InputSample Output
4
1
10.4
2
1.0 2.2
3
1 2 3
5
1 2 3 4 5
Case #1: 10.400
Case #2: 1.600
Case #3: 2.000
Case #4: 3.000



    解题报告: 本人自己WA了好几次,然后看解题报告的。实在很难想到用对数。

    公式很容易推出来,每一项为C(n-1, i)*a[i]/2^(n-1)。难点在于n很大,以至于C(n-1, i)和2^(n-1)都很大,无法直接计算。

    方法呢也很简单,先用对数处理,再做幂运算还原。对数可以递推。

    代码可以改进,可以不开数组,也不用每次都计算log10(2^(n-1)),懒得改了,代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

const int maxn = 55555;
double c[maxn], a[maxn];

int cas=1;
void work()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%lf",a+i);

    c[0]=0;
    for(int i=1;i<n;i++)
        c[i]=c[i-1]+log10(n-i)-log10(i);

    double ans=0;
    for(int i=0;i<n;i++)
        ans+=pow(10.0, c[i]-(n-1)*log10(2))*a[i];

    printf("Case #%d: %.3lf\n", cas++, ans);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
        work();
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值