POJ 2115 C Looooops 解题报告(模线性方程)

96 篇文章 0 订阅
6 篇文章 0 订阅

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16405 Accepted: 4224

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

    题目大意:给定初值,步长,终值,计算机字长,问你循环多少次。

    解题报告:容易知道,Cx=(B-A)(mod 2^k)。解次模线性方程即可,最终求在模n/d系里的解。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long LL;

void gcd(LL a,LL b,LL &d,LL &x,LL &y)
{
    if(b==0)
    {
        d=a;
        x=1;
        y=0;
    }
    else
    {
        gcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}

int main()
{
    int a,b,c,d;
    while(~scanf("%d%d%d%d",&a,&b,&c,&d) && (a||b||c||d))
    {
        if(a==b)
        {
            puts("0");
            continue;
        }
        if(c==0)
        {
            puts("FOREVER");
            continue;
        }

        LL N = 1LL<<d;
        LL B = (N+b-a)%N;
        LL A = c;

        LL d,x,y;
        gcd(A,N,d,x,y);
        if(B%d)
        {
            puts("FOREVER");
        }
        else
        {
            N/=d;
            B/=d;
            LL ans = B*x%N;
            if(ans<0) ans+=N;
            printf("%lld\n", ans);
        }
    }
}


    解模线性方程也基本可以模板化,代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

typedef long long LL;

// 扩展欧几里得
void exgcd(LL a, LL b, LL &d, LL &x, LL &y)
{
    if(b==0)
        d=a, x=1, y=0;
    else
        exgcd(b, a%b, d, y, x), y-=x*(a/b);
}

// 解线性方程ax+by=c,返回最小的正x解
LL linear_mod(LL a, LL b, LL c)
{
    LL d, x, y;
    exgcd(a, b, d, x, y);   // 解ax+by=d, d为a,b最大公约数

    if(c%d) return -1;      // 如果d不能整除c,方程无解

    a/=d, b/=d, c/=d;       // 都除以最大公约数

    if(b<0) b=-b;           // 取正b,如果使用y则y也要换号,此处忽略y

    return (x*c%b+b)%b; // 该方程最小正x解
}

int main()
{
    LL a, b, c, k;

    while(~scanf("%lld%lld%lld%lld", &a, &b, &c, &k) && (a||b||c||k))
    {
        LL ans=0;

        if(c==0 && b-a!=0)
            ans=-1;
        else
            ans=linear_mod(c, 1LL<<k, b-a);

        printf(ans==-1?"FOREVER\n":"%lld\n", ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值