C Looooops
Description
A Compiler Mystery: We are given a C-language style for loop of type
I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.
for (variable = A; variable != B; variable += C) statement;
I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.
Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2
k) are the parameters of the loop.
The input is finished by a line containing four zeros.
The input is finished by a line containing four zeros.
Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input
3 3 2 16 3 7 2 16 7 3 2 16 3 4 2 16 0 0 0 0
Sample Output
0 2 32766 FOREVER题目大意:有一个形如for(i = A;i != B;i += C)的循环,问这个循环能够执行多少次。
解题思路:很显然,问题是求解(A + Cx) ≡ B(mod 2 ^ k)的最小解,移项可得Cx ≡ (B - A) mod (2 ^ k),利用算法导论555页的算法即可求出答案。注意求2 ^ k时的类型转换。
代码如下:
#include <cstdio>
#include <cstring>
typedef long long ll;
ll extended_euclid(ll a,ll b,ll& x,ll& y)
{
ll d = a;
if(b){
d = extended_euclid(b,a % b,y,x);
y -= (a / b) * x;
}
else{
x = 1;
y = 0;
}
return d;
}
ll modular_linear_equation_solver(ll a,ll b,ll n)
{
ll d,x,y;
d = extended_euclid(a,n,x,y);
if(b % d)
return -1;
ll x0 = x * (b / d) % n + n;
return x0 % (n / d);
}
int main()
{
ll a,b,c,k;
while(scanf("%lld %lld %lld %lld",&a,&b,&c,&k) && (a || b || c || k)){
ll ans =modular_linear_equation_solver(c,b - a,(ll)1 << k);
ans == -1 ? printf("FOREVER\n") : printf("%lld\n",ans);
}
return 0;
}