Period
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A
K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it. Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input 3 aaa 12 aabaabaabaab 0 Sample Output Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4 Source |
题意:给定一个长度为n的字符串s,求它的每个前缀的最短循环节。换句话说,对于每个i(2<=i<=n),求一个最大的整数K>1(如果K存在),使得S的前i个字符组成的前缀是某个字符串重复K次得到的。输出所有存在K的i和对应的K。比如对于字符串aabaabaabaab, 只有当i=2,6,9,12时K存在,且分别为2,2,3,4
2406的加强版,2406只判断next[s.size-1],而这道题要把next每个元素都判断一遍
#include <iostream>
using namespace std;
string s;
int p[1000010],l,n=0,i,j,k;
int main()
{
ios::sync_with_stdio(false);
while (cin>>l && l){
n++; cin>>s;
cout<<"Test case #"<<n<<endl;
j=-1; p[0]=-1;
for (i=1;i<l;++i){
while (j>-1 && s[i]!=s[j+1]) j=p[j];
if (s[i]==s[j+1]) ++j;
p[i]=j;
if (p[i]>-1){
k=i-p[i];
if ((i+1)%k==0) cout<<i+1<<' '<<(i+1)/k<<endl;
}
}
cout<<endl;
}
return 0;
}
kdwycz的网站: http://kdwycz.com/
kdwyz的刷题空间:http://blog.csdn.net/kdwycz