南京林业大学“未来之星”第六届程序设计大赛(决赛)试题A 参考代码

A

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 73   Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Potter has been a crush on Susan for long time. Recently, he finds Susan is unhappy, he thinks it is a good chance to approach her. After many efforts, he knows her problem well, but he is not good at computing. She wants to calculate the sum of some integers which are prime numbers(素数).

If you’ve read here, you probably can solve this problem, will you? 

Input

Input contains an integer N(N<=200) in the first line, and then N lines follow. Each line starts with a integer M(M<100), and then M integers(x1 x2 ... xm, abs(xi)<=10000) follow in the same line.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

  
  
2
4 1 2 3
5 1 2 3 4 5

Sample Output

  
  
5
10

Author

mtttt 


参考源码:
#include <iostream>
using namespace std;

int isPrime(int x)
{   
	if(x > 1)//素数指在大于1的自然数中,除了1和此整数自身外,无法被其他自然数整除的数
	{
		int flag=1;
		int k=(int)(sqrt(double(x+1)));
		for(int i=2;i<=k;i++){
			if(x%i==0){
				flag=0;
				break;
			}
		}
		if(flag)
			return 1;
	}
	return 0;
}

int main()
{
	int T;
	cin>>T;
	int M;
	int a[100];
	while(T--){
		cin>>M;
		for (int i = 0; i < M; i++){
			cin>>a[i];
		}
		int sum=0;
		for (int i = 0; i < M; i++){
				if(isPrime(a[i]))
					sum+=a[i];
		}
		cout<<sum<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值