初入算法篇(二分)poj2503

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 47350 Accepted: 19838

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source


题意:给定字符串当做字典,然后给出一段字符串,找找这段字符串是否能在字典中找到,如果找的到输出对应的单词,如果找不到输出eh

很容易这应该用结构体去存放两个字符串,一个是原文,一个是翻译,查找问题,利用快排,然后二分查找,就可以解决了,(sort函数貌似没有字符串排序?)我用了qsort,不过qsort和sort函数总是有点分不清,qsort函数结构体相当于指针要用‘->’不能用‘.’否则报错,然后二分条件mid值也能写错...mid=(L+R)/2  || mid=(R-L)/2+L 有时候记多了容易混淆,以后一律用mid=(L+R)/2,之后我学会了sscanf函数,这是第一次接触这个函数,先gets(str),然后再以str字符串为输入源,输入c[i].a,c[i].b中,好了上代码

#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdio>

using namespace std;
struct node
{
    char a[100];
    char b[100];
}c[100009];
int i;
int cmp(const void *f,const void *g)
{
    struct node *ff=(struct node *)f;
    struct node *gg=(struct node *)g;
    return strcmp(ff->b,gg->b);
}
int bs(char str[])
{
    int L=0,R=i-1;
    while(L<=R)
    {
        int mid=(R-L)/2+L;
        if(strcmp(c[mid].b,str)==0) return mid;
        else if(strcmp(str,c[mid].b)>0) L=mid+1;
        else R=mid-1;
    }
    return -1;
}
int main()
{
    char str[50];
    int j;
    i=0;
    while(gets(str))
    {

        if(str[0]=='\0') break;
        sscanf(str,"%s%s",c[i].a,c[i].b);
        i++;
    }
    qsort(c,i,sizeof(c[0]),cmp);
    while(gets(str))
    {
       int  k=bs(str);
        if(k==-1) printf("eh\n");
        else printf("%s\n",c[k].a);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值