数据结构篇(并查集)基础模板+poj2524

亲戚关系:给出m对亲戚关系,如果a和b是亲戚,b和c是亲戚,那么a和c也是亲戚,给出k个询问,问每对询问的两个值是否是亲戚,如果是输出Yes,不是输出No

典型并查集模板

#include <iostream>
#include <cstdio>
using namespace std;
int father[20001];
int find(int x)
{
    int root=x,temp;
    while(father[root]>=0)
    {
        root=father[root];//回溯找到根节点
    }
    while(root!=x)//压缩路径
    {
        temp=father[x];//临时保存原本父节点
        father[x]=root;//将这一点父节点变成根节点
        x=temp;//将原本父节点也进行下一次循环,将这点的父节点变成根
    }
    return root;//返回根节点
}
void Union(int a,int b)//合并集合
{
    int temp=father[a]+father[b];
    if(father[a]>father[b])
    {
        father[a]=b;//小的才是根节点
        father[b]=temp;
    }
    else
    {
        father[b]=a;
        father[a]=temp;
    }
}
int main()
{
    int n,m,a,b,i,j,k;
    scanf("%d%d%d",&n,&m,&k);
    for(i=1;i<=n;i++)
    {
        father[i]=-1;
    }
    while(m--)
    {
        scanf("%d%d",&a,&b);
        if(find(a)!=find(b))//a与b联通,但根节点不同,合并集合
        {
            Union(a,b);
        }
    }
    while(k--)
    {
        scanf("%d%d",&a,&b);
        if(find(a)!=find(b)) printf("No\n");
        else printf("Yes\n");
    }
}

上面这个算法个人认为耗时极大,因为回溯找根节点,和路径压缩都是分开的,那么会导致复杂度增加,这是经历过poj2524我才明白的道理

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.

这题目也是并查集简单应用,一开始先假设全部人的宗教都不同,有n个宗教,接着如果宗教相同,那么归到一个集合里面去,这一个集合里面都是同一个宗教的,所以合并一次,n--,最终输出n

#include <iostream>
#include <stdio.h>
using namespace std;
int father[50000];
int Find(int x)
{
    /*int root=x;
    while(father[root]>=0)
    {
        root=father[root];
    }
    while(root!=x)
    {
        int temp=father[x];
        father[x]=root;
        x=temp;
    }
    return root;*/
    if(x!=father[x])
    {
        father[x]=Find(father[x]);//压缩路径
    }
    return father[x];
}
void Union(int a,int b)//合并
{
    int x=Find(a);
    int y=Find(b);
    if(x!=y) father[x]=y;
}
int main()
{
    int a,b,n,m,i,t=1;
    while(scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        for(i=1; i<=n; i++) father[i]=i;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(Find(a)!=Find(b))
            {
                Union(a,b);
                n--;
            }
        }
        printf("Case %d: ",t++);
        printf("%d\n",n);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值