Maya Calendar(POJ1008)

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.
For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.
Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:
1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .
Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:
Haab: 0. pop 0
Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

Input

The date in Haab is given in the following format: NumberOfTheDay.
Month Year The first line of the input file contains the number of the
input dates in the file. The next n lines contain n dates in the Haab
calendar format, each in separate line. The year is smaller then 5000.

Output

The date in Tzolkin should be in the following format: Number
NameOfTheDay Year The first line of the output file contains the
number of the output dates. In the next n lines, there are dates in
the Tzolkin calendar format, in the order corresponding to the input
dates.

Sample Input

3
10. zac 0
0. pop 0
10. zac 1995

Sample Output

3
3 chuen 0
1 imix 0
9 cimi 2801*

#include<iostream>
#include<string>
using namespace std;
string Haab[19]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen",
				"yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
string Tzolkin[20]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk",
					"ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
					//单词别看走眼了 
struct data{
	public:
		int year;
		string month;
		int day;
};

void convert(data&t){
	long allday;
	int i,out1,out3=0;
	string out2;
	for(i=0;i<19;i++)
			if(t.month==Haab[i])		//	匹配对应的月份 
				break;
	allday=i*20+365*t.year+(t.day+1);	//Haab历从"0"开始计,因此要 +1 , 
										//所有天数为 年数 * 365,和这个月前面所有月数 * 20 
	if(allday%13==0)					//数字以 13 为周期 
		out1=13;
	else 
		out1=allday%13;
	while(allday>260){
		out3++;
		allday-=260;	
	}
	if(allday==0)						//余数为 0 时,代表当年的最后一天。 
		out2="ahua";
	else {
		while(allday>20){				//单词以 20 为一个周期 
			allday-=20;
		}
		if(allday==0)
			out2="ahua";
		else 
			out2=Tzolkin[allday-1];
	}
	
	cout<<out1<<" "<<out2<<" "<<out3<<endl;
}
int main(){
	int N,i;
	char ch;
	data t;
	cin>>N;
	data *p=new data[N];
	for(i=0;i<N;i++)
		cin>>p[i].day>>ch>>p[i].month>>p[i].year;		//ch,注意句号的输入 
	cout<<N<<endl;							//一起输出的还有列数(就nm离谱) 
	for(i=0;i<N;i++)
		convert(p[i]);
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值