Titanic(POJ2361)

It is a historical fact that during the legendary voyage of “Titanic” the wireless telegraph machine had delivered 6 warnings about the danger of icebergs. Each of the telegraph messages described the point where an iceberg had been noticed. The first five warnings were transferred to the captain of the ship. The sixth one came late at night and a telegraph operator did not notice that the coordinates mentioned were very close to the current ship’s position.
Write a program that will warn the operator about the danger of icebergs!
The input messages are of the following format:
Message #<n>.
Received at <HH>:<MM>:<SS>.
Current ship’s coordinates are
<X1>^<X2>’<X3>" <NL/SL>
and <Y1>^<Y2>’<Y3>" <EL/WL>.
An iceberg was noticed at
^’" <NL/SL>
and ^’" <EL/WL>.
===
Here is a positive integer, :: is the time of the
message reception, <X1>^<X2>’<X3>" <NL/SL> and <Y1>^<Y2>’<Y3>" <EL/WL>
means “X1 degrees X2 minutes X3 seconds of North (South) latitude and
Y1 degrees Y2 minutes Y3 seconds of East (West) longitude.”

Output

Your program should print to the output file message in the following format:

The distance to the iceberg: <s> miles.

Where <s> should be the distance between the ship and the iceberg,
(that is the length of the shortest path on the sphere between the
ship and the iceberg). This distance should be printed up to (and
correct to) two decimal digits. If this distance is less than (but not
equal to!) 100 miles the program should print one more line with the
text:

DANGER!

Sample Input

Message #513.
Received at 22:30:11.
Current ship’s coordinates are
41^46’00" NL
and 50^14’00" WL.
An iceberg was noticed at
41^14’11" NL
and 51^09’00" WL.
===

Sample Output

The distance to the iceberg: 52.04 miles. DANGER!

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
using namespace std;
double pi=acos(-1.0);		//	acos()函数不接受 int型,否则将编译错误 
double R=3437.5;			//地球半径(英里) 
inline void change(double &x,double &y){
	x=x*pi/180;
	y=y*pi/180;
 }
	//A(wa,jb),B(wx,jy),w 表示维度; j 表示经度。北纬、东经取正 
void distance(double a,double b,double x,double y){
	double d;
	//为计算地球两点的距离公式,请自行推导 
	d=R* acos(cos(a)*cos(x)*cos(b-y)+sin(a)*sin(x));	
	printf("The distance to the iceberg: %.2lf miles.\n",d);
	if(floor(d+0.005)<100)
		cout<<"DANGER!\n";
}
int main(){
	string s;
	double a1,a2,a3,b1,b2,b3,shipw,shipj,icebergw,icebergj;
	char a,b;
	int i;
	for(i=0;i<3;i++)
		getline(cin,s);			
	scanf("%lf^%lf'%lf\" %cL ",&a1,&a2,&a3,&a);	
	scanf("and %lf^%lf'%lf\" %cL.",&b1,&b2,&b3,&b);
			
	shipw=a1+ a2/60+ a3/3600;
	shipj=b1+ b2/60+ b3/3600;
	if(a=='S')	shipw*=-1;
	if(b=='W')	shipj*=-1;
	
	change(shipw,shipj);

	getchar();	//当 getline函数 前使用过 scanf函数 需要getchar()读取未被scanf读到的 \n 
	getline(cin,s);	
	scanf("%lf^%lf'%lf\" %cL ",&a1,&a2,&a3,&a);
	scanf("and %lf^%lf'%lf\" %cL.",&b1,&b2,&b3,&b);
						
	icebergw=a1+ a2/60 +a3/3600;
	icebergj=b1+ b2/60 +b3/3600;
	if(a=='S')	icebergw*=-1;
	if(b=='W')	icebergj*=-1;
	
	change(icebergw,icebergj);
	getchar();
	getline(cin,s);	
	distance(shipw,shipj,icebergw,icebergj);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值