Largest Rectangle in a Histogram【单调栈(类二)】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36011 Accepted: 11763


Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.


Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.


Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output
8
4000


中文翻译
题意 : 给定从左到右多个矩形,已知这此矩形的宽度都为1,长度不完全相等。这些矩形相连排成一排,求在这些矩形包括的范围内能得到的面积最大的矩形,打印出该面积。所求矩形可以横跨多个矩形,但不能超出原有矩形所确定的范围


解题思路
分析 : 建立一个单调递增栈,所有元素各进栈和出栈一次即可。每个元素出栈的时候更新最大的矩形面积。
让我们来模拟一下,会更清晰。
在这里插入图片描述


代码

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
long long n,a[100010],ans,top,tmp,tot;
struct c{
	long long h,w;
}s[100010];
int main(){
	scanf("%lld",&n);
	while(n!=0)
	{
		for(int i=1;i<=n;i++)
			scanf("%lld",&a[i]);
		ans=0,top=1,tot=0;
		memset(s,0,sizeof(s));
		for(int i=1;i<=n;i++)
		{
			tot=0;
			while(top>0&&a[i]<=s[top-1].h)
			{
				tmp=s[top-1].h*(tot+s[top-1].w);
				ans=max(ans,tmp);
				tot+=s[top-1].w;
				top--;
			}
			s[top].h=a[i];
			s[top].w=tot+1;
			top++;
		}
		tot=0;
		while(top>0)
		{
			tmp=s[top-1].h*(tot+s[top-1].w);
			ans=max(ans,tmp);
			tot+=s[top-1].w;
			top--;
		}
		printf("%lld\n",ans);
		scanf("%lld",&n);
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值