uva 305 Joseph(约瑟夫环解+打表)

737 篇文章 0 订阅
24 篇文章 0 订阅

 Joseph 

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, ..., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30
题目大意:有一個惡名昭彰的故事:某部落酋長有n個俘虜(編號從1,2,3,……,n),他叫他們排成一個圈圈,然後開始數,第m 個人要被煮來吃掉(第一次從編號1的人開始數),按照此規則繼續下去,直到只剩下一個人,那一個人可以保留性命。例如:n=6, m=5則被吃掉的人的編號依序是5,4,6,2,3最號只有編號 1活了下來。Joseph 是個很聰明的人,他總是能挑到最後存留的位置,所以這件事才被披露出來。 現在假設共有2k個人,其中排在編號 1 到 k 的是好人,排在編號 k+1 到 2k 的是壞人,你的任務就是要找出一個最小的 m,使得在所有 k 個壞人被吃掉之前,沒有一個好人會被吃掉。

解题思路:约瑟夫环的公式ai+1 = (ai + set) %sum  ai表示第i个被吃掉的人,set表示步数,sum表示当前还剩余的人数。(这道题目必须打表,不然超时)

#include<stdio.h>
#include<string.h>

int num[15];
int judge(int set, int k){
	int now, t = 0, f, sum = 2 * k ,cnt = 0;
	while (1){
		now = (set - t - 1) % sum + 1;
		if (now <= k)
			return 0;
		t = sum - now;
		sum--;
		cnt++;
		if(cnt == k)
			return 1;
	}
}

int main(){
	for (int i = 1;i < 14; i++)
	{	int j;
		for (j = i; ;j++)
			if (judge(j, i))
				break;
		num[i] = j;
	}
	int k;
	while (scanf("%d", &k), k){
		printf("%d\n",num[k]);
	}
	return 0;}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值