UVA 305 Joseph (约瑟夫环 打表)

 Joseph 

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, ..., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

假设有2k个人围着一个圆桌坐着,前k个是好人,后k个是坏人 。现在开始,每m个人踢掉一个,比如有6个人,m=5,那么,被踢掉的人依次是5,4,6,2,3,1。现在要求,在踢掉第一个好人前,必需把所有的坏人踢掉,问,给定一个k,求满足这个要求的最小的m。

思路:

直接模拟会超时。。约瑟夫环的问题可以推出数学的公式。。再由公式去模拟

当前位置 = (步数 + 当前位置) % 人数 (注意。。如果为0.说明是到了最后一个位置)

因为好人为前K个。 所以如果当前位置在区间[1,  K]就不满足。

每次找完一个人之后。把这个人除去。所以位置要前移一位。。

然后人数减一。。如果人数减少到k个了。就表明这次是成立的

这样进行模拟就可以大大减少时间。。。

但是。。但是还是会超时。。最后只能去打表- - 无语。。。

#include <stdio.h>

int main()
{
    int n;
    int sb[14];
    for (n = 1; n <= 13; n ++)
    {
	int k;
	for (k = n + 1; k < 2000000000; k ++)
	{
	    int num = 2 * n;
	    int wei = 0;
	    int judge = 0;
	    int s = 0;
	    while (1)
	    {
		wei = (k + wei) % num;
		if (wei <= n && wei >= 1)
		    break;
		if (wei == 0)
		    wei += num;
		wei --;
		num --;
		if (num == n)
		{
		    judge = 1;
		    break;
		}	
	    }
	    if (judge)
		break;
	} 
	sb[n] = k;
    }
    int m;
    while (scanf("%d", &m) != EOF && m)
    {
	printf("%d\n", sb[m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值