Problem M
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 27 Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
思路:还是很简单的bfs。
代码实现:
#include <stdio.h>
#include <string.h>
struct queuenode{ //建结构
int a, b;
}queue[100000];
int count, sx, sy, tx, ty, head = 0,tail = 0; //定义
int a, b, n, temp;
int dir[4][2] = { {1,0} , {0,1} , {-1,0} , {0,-1} };
bool map[110][110];
int m, k, i, j;
int inarea(int x,int y) //判断是否在区域内
{
return x >= 0 && y >= 0 && x < a && y < b;
}
void bfs( ) //bfs
{
tail = head;
queue[head].a = sx; //初始化队列头部
queue[head].b = sy;
map[sx][sy] = 1;
while(head <= tail){ //在队列中有数据的情况下进行循环
for(k = 0;k < 4; k++){ //四个方向
tx = queue[head].a + dir[k][0];
ty = queue[head].b + dir[k][1];
if(inarea(tx, ty) && map[tx][ty]== 0){
tail++;
count++;
queue[tail].a = tx;
queue[tail].b = ty;
map[tx][ty] = 1;
}
}
head++;
}
return;
}
int main(void) //主函数
{
while(scanf("%d%d",&b,&a)==2&&b!=0){
memset(map, 1, sizeof(map));
while(scanf(" ")||scanf("\n")) ;
for(i = 0;i < a; i++){ //扫描地图
for(j = 0;j < b; j++){
scanf("%c",&temp);
if (temp == '#') map[i][j] = 1;
else if (temp == '.') map[i][j] = 0;
else if (temp == '@') {
map[i][j] = 0;
sx = i;
sy = j;
}
else {
j--;
continue;
}
}
}
count = 1;
bfs(); //进入bfs
printf("%d\n",count);
}
return 0;
}