dp求最大和序列

Problem C

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 89 Accepted Submission(s) : 16
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

思路分析:

从第一个正值开始计算和,储存最大和到max并标记首尾;遇到总和为负数则结束此次动态规划,从下一个正值继续。


代码实现:

#include <stdio.h>
int main()
{
	int i, j, N, n, sum, start, end, max, tmp, tstart;
	scanf("%d",&N);
	for (i = 1;i <= N;i ++) {
		scanf("%d",&n);
		sum = 0;
		tstart = 1;
		max = -10000;
		for (j = 1;j <= n;j ++) {
			scanf("%d",&tmp);
			sum += tmp;
			if (sum > max) {
				start = tstart;
				end = j;
				max = sum;
			}
			if (sum < 0) {
				sum = 0;
				tstart = j + 1;
			}
		}
		printf("Case %d:\n%d %d %d\n",i, max, start, end);
		if (i != N ) printf("\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值