bfs可恶的大魔王

Problem I

Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 70 Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11


思路:bfs。然后再剪枝剪去a+b+c-3>n的情况。

代码实现:

#include <stdio.h>
#include <string.h
struct queuenode{								//建结构
	int a, b, c, n;
	}queue[100000];

int ct, tx, ty, tz, head = 0,tail = 0;			//定义
int a, b, c, n, temp;
int dir[6][3] = { {1,0,0} , {0,1,0} , {0,0,1} , {-1,0,0} , {0,-1,0} , {0,0,-1} };
bool map[60][60][60];
int m, p, i, j, k;
int inarea(int x,int y,int z)					//判断是否在区域内
{
	return x >= 0 && y >= 0 && z >= 0 && x <= a && y <= b && z <= c;
}

void bfs(  )									//bfs
{
	if (a + b + c - 3 > n) {					//剪枝
		printf("-1\n");
		head++;
		tail = head;
		return;
	}
	queue[head].a = 0;							//初始化队列头部
	queue[head].b = 0;
	queue[head].c = 0;
	queue[head].n = 0;
	map[0][0][0] = 1;
	while(queue[head].n <= n && head <= tail){	//在队列中有数据并且步数在限制之内的情况下进行循环
		if (queue[head].a == a-1 && queue[head].b == b-1 && queue[head].c == c-1 && queue[head].n <=n){	//退出条件
			printf("%d\n",queue[head].n);
			head++;
			tail = head;
			return;
		}
		for(ct = 0;ct < 6; ct++){				//六个方向
			tx = queue[head].a + dir[ct][0];
			ty = queue[head].b + dir[ct][1];
			tz = queue[head].c + dir[ct][2];
			if(inarea(tx, ty, tz)&&map[tx][ty][tz]== 0){
				tail++;
				queue[tail].a = tx;
				queue[tail].b = ty;
				queue[tail].c = tz;
				queue[tail].n = queue[head].n + 1;
				map[tx][ty][tz] = 1;
			}
		}
		head++;
	}
	if (queue[head].n > n || head > tail){		//如果超过步数或者走不通,返回-1
		printf("-1\n");
		head++;
		tail = head;
		return;
	}
}
		
int main(void)									//主函数
{
	scanf("%d",&m);
	for(p = 0;p < m;p++){						
		scanf("%d%d%d%d",&a,&b,&c,&n);			
		memset(map, 1, sizeof(map));			//初始化地图
		for(i = 0;i < a; i++){					//扫描地图
			for(j = 0;j < b; j++){
				for(k = 0;k < c; k++){
					scanf("%d",&temp);
					if(temp == 1) map[i][j][k] = 1;
					 else
					 map[i][j][k] = 0;
				}
			}
		}
		bfs();									//进行bfs
	}
	return 0;
}
	

结果 
531 MS640 KB
开始没有初始化地图,错了好几遍,改完之后就没问题了,主要是bfs的题目第一次做不太熟练的原因= =

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值