USACO Section 2.1 Healthy Holsteins

题目原文

Healthy Holsteins
Burch & Kolstad

Farmer John prides himself on having the healthiest dairy cows in the world. He knows the vitamin content for one scoop of each feed type and the minimum daily vitamin requirement for the cows. Help Farmer John feed his cows so they stay healthy while minimizing the number of scoops that a cow is fed.

Given the daily requirements of each kind of vitamin that a cow needs, identify the smallest combination of scoops of feed a cow can be fed in order to meet at least the minimum vitamin requirements.

Vitamins are measured in integer units. Cows can be fed at most one scoop of any feed type. It is guaranteed that a solution exists for all contest input data.

PROGRAM NAME: holstein

INPUT FORMAT

Line 1:integer V (1 <= V <= 25), the number of types of vitamins
Line 2:V integers (1 <= each one <= 1000), the minimum requirement for each of the V vitamins that a cow requires each day
Line 3:integer G (1 <= G <= 15), the number of types of feeds available
Lines 4..G+3:V integers (0 <= each one <= 1000), the amount of each vitamin that one scoop of this feed contains. The first line of these G lines describes feed #1; the second line describes feed #2; and so on.

SAMPLE INPUT (file holstein.in)

4
100 200 300 400
3
50   50  50  50
200 300 200 300
900 150 389 399

OUTPUT FORMAT

The output is a single line of output that contains:

  • the minimum number of scoops a cow must eat, followed by:
  • a SORTED list (from smallest to largest) of the feed types the cow is given
If more than one set of feedtypes yield a minimum of scoops, choose the set with the smallest feedtype numbers.

SAMPLE OUTPUT (file holstein.out)

2 1 3


分析

题目看起来挺复杂的,其实解法非常简单粗暴,由于G的最大值为15,所有最大的解空间为2^15=32768,直接枚举所有的可能性是能够接受的,深搜把所有情况遍历一遍就可以了。

提交代码

/*
ID: Aaron Cai
PROG: holstein
LANG: C++
*/



#include <iostream>
#include <fstream>
#include <vector>
#include <algorithm>
#include <string>
#include <math.h>
#include <limits>
#include <map>
using namespace std;

int V,G;
vector<int> req;
vector<vector<int> > feeds;
vector<int> feeded;
vector<int> result;

int minscoop=16;

bool satisfy()
{
	if(req.size() != feeded.size())
		return false;

	bool out = true;
	for (int i=0;i!=req.size();i++)
	{
		out = out && req[i]<=feeded[i] ;
		if(!out)
			return out;
	}

	return out;
}


void search(int scoop,int scoopcnt,vector<int> &record)
{
	if(scoop+1 > G)
		return;

	for (int i=0;i!=V;i++)
	{
		feeded[i] += feeds[scoop][i];
	}
	record.push_back(scoop);
	if(satisfy())
	{
		if(scoopcnt+1 < minscoop)
		{
			minscoop = scoopcnt + 1;
			result.clear();
			result = record;
		}
	}
	else
	{
		search(scoop+1,scoopcnt+1,record);
	}

	for (int i=0;i!=V;i++)
	{
		feeded[i] -= feeds[scoop][i];
	}
	record.pop_back();
	search(scoop+1,scoopcnt,record);
}


int main()
{
	ifstream fin("holstein.in");
	ofstream fout("holstein.out");

	fin>>V;
	req.resize(V);
	feeded.resize(V,0);
	for (int i=0;i!=V;i++)
	{
		fin >> req[i];
	}
	fin >>G;
	feeds.resize(G);
	
	for (int i=0;i!=G;i++)
	{
		feeds[i].resize(V);
		for(int j=0;j!=V;j++)
		{
			fin >> feeds[i][j];
		}
	}

	result.resize(15);
	vector<int> record;
	search(0,0,record);

	fout << minscoop << " ";
	for (int i=0;i!=result.size()-1;i++)
	{
		fout<< result[i]+1 << " ";
	}
	fout << result[result.size()-1]+1 << endl;

	return 0;
}

提交结果

TASK: holstein
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.008 secs, 3504 KB]
   Test 2: TEST OK [0.008 secs, 3504 KB]
   Test 3: TEST OK [0.005 secs, 3504 KB]
   Test 4: TEST OK [0.005 secs, 3504 KB]
   Test 5: TEST OK [0.005 secs, 3504 KB]
   Test 6: TEST OK [0.008 secs, 3504 KB]
   Test 7: TEST OK [0.008 secs, 3504 KB]
   Test 8: TEST OK [0.011 secs, 3504 KB]
   Test 9: TEST OK [0.011 secs, 3504 KB]
   Test 10: TEST OK [0.016 secs, 3504 KB]

All tests OK.


官方参考答案

#include <stdio.h>
#include <assert.h>

#define MAXV 25
#define MAXF 15

int req[MAXV]; /* the vitamin requirements */
int numv; /* number of vitamins */

int feeds[MAXF][MAXV]; /* the vitamin within each feed */
int numf; /* number of feeds */

int best; /* the minimum number of feeds to use found thus far */
int bestf[MAXF]; /* the set */

int curf[MAXF]; /* the current set of feeds being considered */

void find_feed(int fcnt, int fid)
 { /* fcnt is the number of feeds in the current mixture,
      fid is the identifier of the first feed to try adding (last feed + 1) */
  int lv;

  /* check if the requirement has been met */
  for (lv = 0; lv < numv; lv++)
    if (req[lv] > 0) break; 
  if (lv >= numv)
   { /* all the requirements are met */
    /* we know this is better, since we wouldn't have checked it otherwise
       (see below) */
    best = fcnt;
    for (lv = 0; lv < best; lv++)
      bestf[lv] = curf[lv];
    return;
   }

  while (fid < numf && fcnt+1 < best)
   { /* try adding each feed to the mixture */
     /* the fcnt+1 < best ensures that we stop if there's no hope
	in finding a better solution than one found already */

    /* add the vitamins from this feed */
    for (lv = 0; lv < numv; lv++)
      req[lv] -= feeds[fid][lv]; 
    curf[fcnt] = fid; /* put it in the list */

    find_feed(fcnt+1, fid+1); 

    /* undo adding the vitamins */
    for (lv = 0; lv < numv; lv++)
      req[lv] += feeds[fid][lv];

    /* next feed */
    fid++;
   }
 }

int main(void) 
 {
  FILE *fin, *fout;
  int lv, lv2;

  fin = fopen("holstein.in", "r");
  fout = fopen("holstein.out", "w");
  assert(fin);
  assert(fout);

  fscanf (fin, "%d", &numv);
  for (lv = 0; lv < numv; lv++)
    fscanf (fin, "%d", &req[lv]);
  fscanf (fin, "%d", &numf);
  for (lv = 0; lv < numf; lv++)
    for (lv2 = 0; lv2 < numv; lv2++)
      fscanf (fin, "%d", &feeds[lv][lv2]);

  best = numf+1;
  find_feed(0, 0);

  fprintf (fout, "%i", best);
  for (lv = 0; lv < best; lv++) 
    fprintf (fout, " %i", bestf[lv]+1);
  fprintf (fout, "\n");
  return 0;
 }

THE END


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值