数据结构实验之链表七:单链表中重复元素的删除

  • Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

  • Input

第一行输入元素个数 n (1 <= n <= 15); 第二行输入 n 个整数,保证在 int 范围内。

  • Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

  • Example Input

10
21 30 14 55 32 63 11 30 55 30

  • Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int i,n;
    struct node *head,*p,*q,*t;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    printf("%d\n",n);
    p=head->next;
    for(i=1;i<=n;i++)
    {
        if(i!=n)
        printf("%d ",p->data);
        else printf("%d\n",p->data);
        p=p->next;
    }
    p=head->next;
    while(p!=NULL)//外循环以p开始  
    {
        t=p;
        q=t->next;// t指针总为q指针的前一位,方便释放内存及连接q的前后
        while(q!=NULL)
        {
            if(p->data==q->data)
            {
                n--;
                t->next=q->next;
                free(q);
                q=t->next;//继续后移
            }
            else
            {
                t=t->next;
                q=q->next;//无相等的,同时后移
            }
        }
        p=p->next;    //下次循环
    }
    p=head->next;
    printf("%d\n",n);
    for(i=1;i<=n;i++)
    {
        if(i!=n)
        printf("%d ",p->data);
        else printf("%d\n",p->data);
        p=p->next;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值