查询线段树 Balanced Lineup POJ - 3264

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 56169 Accepted: 26321
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

这个线段树简单啊。。 都不用更新节点
下面两个代码思路相同。只是第二个更简洁些。
看来 RMQ确实需要学了。。。
RMQ比线段树解决这个要快


类似题目推荐:http://blog.csdn.net/khn64/article/details/77374114


1.超简单写法。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define inf 0x3f3f33f
#define ms(x) memset(x, 0, sizeof(x))
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
#define mid  (r+l)>>1
using namespace std;
const int N = 50001;
int ma[N<<2];
int mi[N<<2];
inline void PushUpmax(int rt)
{
    ma[rt] = max(ma[rt<<1], ma[rt<<1|1]);
}
inline void PushUpmin(int rt)
{
    mi[rt] = min(mi[rt<<1], mi[rt<<1|1]);
}
void build(int l, int r, int rt)
{
    if(l == r)
    {
        int t;
        scanf("%d",&t);
        mi[rt] = t;
        ma[rt] = t;
        return ;
    }
    int m = mid;
    build(lson);
    build(rson);
    PushUpmax(rt);
    PushUpmin(rt);
}
int queryma(int x, int y, int l, int r, int rt)
{
    if(x<=l && r<=y)
    {
        return ma[rt];
    }
    int m = mid;
    int ret = 0;
    if(x <= m) ret = max(ret, queryma(x,y,lson));
    if(m < y) ret = max(ret, queryma(x,y,rson));
    return ret;
}
int querymi(int x, int y, int l, int r, int rt)
{
    if(x<=l && r<=y)
    {
        return mi[rt];
    }
    int m = mid;
    int ret = inf;
    if(x <= m) ret = min(ret, querymi(x,y,lson));
    if(m < y) ret = min(ret, querymi(x,y,rson));
    return ret;
}
int main()
{
    int n, q;
    while(cin>>n>>q)
    {
        build(1, n, 1);
        while(q--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            printf("%d\n",queryma(x,y,1,n,1)-querymi(x,y,1,n,1));
        }
    }
    return 0;
}

2.  查询区间最大值与最小值合并

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define inf 0x3f3f33f
#define ms(x) memset(x, 0, sizeof(x))
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
#define mid  (r+l)>>1
using namespace std;
const int N = 50001;
int ma[N<<2];
int mi[N<<2];
int up,down;
inline void PushUpmax(int rt)
{
    ma[rt] = max(ma[rt<<1], ma[rt<<1|1]);
}
inline void PushUpmin(int rt)
{
    mi[rt] = min(mi[rt<<1], mi[rt<<1|1]);
}
void build(int l, int r, int rt)
{
    if(l == r)
    {
        int t;
        scanf("%d",&t);
        mi[rt] = t;
        ma[rt] = t;
        return ;
    }
    int m = mid;
    build(lson);
    build(rson);
    PushUpmax(rt);
    PushUpmin(rt);
}
void query(int x, int y, int l, int r, int rt)
{
    if(x<=l && r<=y)
    {
        up = max(up,ma[rt]);
        down = min(down, mi[rt]);
        return ;
    }
    int m = mid;
    if(x <= m)
    {
        query(x,y,lson);
    }
    if(m < y)
    {
        query(x,y,rson);
    }
}
int main()
{
    int n, q;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        build(1, n, 1);
        while(q--)
        {
            up = 0;
            down = inf;
            int x,y;
            scanf("%d%d",&x,&y);
            query(x,y,1,n,1);
            printf("%d\n",up-down);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值