深搜 基础



Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

—————————————————————————————————————————————————————————————————————————————

分界线

—————————————————————————————————————————————————————————————————————————————

这个题很明显是深搜的问题 第一次wa是因为一些细节原因(复制粘贴惹的祸)  第二次是字母表的顺序没调对,最后一次 得怪可恶的空行!!!!!!!!!!!


下面就是代码了 注意字母表的规律的时候一定要注意+2 +1的细节之差.....(说多了都是泪)


#define _CRT_SECURE_NO_WARNINGS//vs防报错  scanf不安全....
#include<cstdio>
#include<cstring>

int vis[100][100];
int a, b, i, j, flag;
void trav(int x, int y, int n)
{
	int o;
	if (flag == 1)return;//一旦找到就退出
	if (vis[x][y] == 0 && x >= 1 && x <= a&&y >= 1 && y <= b){//判定是否在局内
		if (n >= a*b&&flag != 1){//找到了就出结果
			vis[x][y] = n;
			flag = 1;
			for (o = 1; o <= a*b; o++){
				for (i = 1; i <= a; i++){
					for (j = 1; j <= b; j++){
						if (vis[i][j] == o)printf("%c%d", i + 'A' - 1, j);//vis记录数据 这样可能导致计算的时候效率低下 可以采用struct来弥补这个问题
					}
				}
			}
			printf("\n");
		}
		vis[x][y] = n;//标记为已经寻的
		n++;
		trav(x - 2, y - 1, n);
		trav(x - 2, y + 1, n);
		trav(x - 1, y - 2, n);
		trav(x - 1, y + 2, n);
		trav(x + 1, y - 2, n);
		trav(x + 1, y + 2, n);
		trav(x + 2, y - 1, n);
		trav(x + 2, y + 1, n);//8方向遍历
		vis[x][y] = 0;//如果什么都不成功 返回到上一步
	}
	return;
}
int main()
{
	int i, n;
	//freopen("test.txt", "r", stdin);
	scanf("%d", &n);
	for (i = 0; i<n; i++){
		scanf("%d%d", &b, &a);
		flag = 0;
		printf("Scenario #%d:\n", i + 1);
		memset(vis, 0, sizeof(vis));
		trav(1, 1, 1);
		if (flag == 0)printf("impossible\n");
		if(i!=n-1)printf("\n");//唯有泪千行!!!!!!!!一定!!!!!!
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值