HDOJ 4293 dp

Description

  According to a research, VIM users tend to have shorter fingers, compared with Emacs users. 
  Hence they prefer problems short, too. Here is a short one: 
  Given n (1 <= n <= 10  18), You should solve for 
g(g(g(n))) mod 10  9 + 7

  where 
g(n) = 3g(n - 1) + g(n - 2)

g(1) = 1

g(0) = 0

 

Input

  There are several test cases. For each test case there is an integer n in a single line. 
  Please process until EOF (End Of File). 
 

Output

  For each test case, please print a single line with a integer, the corresponding answer to this case. 
 

Sample Input

       
       
0 1 2
 

Sample Output

       
       
0 1 42837
 

就是一个裸的dp

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[503],sum[503][503],maxs,n,i,j,t1,t2,p,ans;
int main(){
    while (scanf("%d",&n)!=EOF){
        p=0;
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        for (i=0;i<n;i++){
            scanf("%d%d",&t1,&t2);
            if (t1+t2+1<=n){
                p++;
                sum[t1+1][n-t2]++;
                if (sum[t1+1][n-t2]>n-t2-t1) sum[t1+1][n-t2]=n-t2-t1;
            }
        }
        ans=0;
        for (i=1;i<=n;i++){
            maxs = 0;
            dp[i] = dp[i-1];
            for (j = 0 ;j < i;j++){
                if (maxs<dp[j]+sum[j+1][i]) maxs= dp[j] + sum[j+1][i];
                if (ans<maxs) ans = maxs;
                }
            if (dp[i]<maxs) dp[i] = maxs;
        }
        printf("%d\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值