hoj 1015 Nearly prime numbers

Nearly prime numbers

My Tags  (Edit)
  Source : Unknown
  Time limit : 1 sec   Memory limit : 1 M

Submitted : 5032, Accepted : 888

Nearly prime number is an integer positive number for which it is possible to find such primes P1 and P2 that given number is equal toP1*P2. There is given a sequence on N integer positive numbers, you are to write a program that prints Yes if given number is nearly prime and No otherwise.

Input

Input consists of N+1 numbers. First is positive integer N (1<=N<=50000). Next N numbers followed by N. Each number is not greater than 109. All numbers separated by whitespace(s).

Output

Write a line in output for each number of given sequence. Write Yes if given number is nearly prime and No in other case.

Sample Input
1
6
Sample Output
Yes
题意是:问一个数能否化成两个素数的乘积。
可以先用筛选法处理前40000个素数,再比较可知、
坑点是什么。用c++的话,iostream 就直接超内存了
一定要用stdio



#include <stdio.h>
using namespace std;
int prime[35000];
bool isprime(int a)
{
if(a<2) return false;
for(int i=2;i*i<=a;i++)
{
if(a%i==0) return false;
}
return true;
}


int main()
{
int t;
scanf("%d",&t);
int top=0;
for(int i=2;i<=35000;i++) if(isprime(i)==1) {prime[top]=i;top++;}


while(t--)
{
int n;
scanf("%d",&n);
int flag=0;
for(int i=0;i<top;i++)
{
if(n%prime[i]==0&&isprime(n/prime[i]))
{
flag=1;
printf("Yes\n");
break;
}
}
if(flag==0) printf("No\n");
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值