poj1679The Unique MST 次小生成树

19 篇文章 0 订阅
The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21580 Accepted: 7636

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source


先求出最小生成树,记录最小生成树的每条边,除去这些边构造出的新的最小生成树总和最小的就是次小生成树了

code:
#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
#define Max 102
#define Maxx 5002


struct edge
{
    int u,v;
    int w;
}edges[Maxx];
int n,m,p[Max],sum;




bool cmp(edge a,edge b)
{
    if(a.w<b.w) return true;
    return false;
}


void build()
{
    for(int x=1;x<=n;x++)
        p[x]=x;
}


int look(int x)
{
    if(x!=p[x])
        p[x]=look(p[x]);
    return p[x];
}
bool uni;
void kruskal()
{
    int x,y;
    int a[Max],numm,k=0;
    build();
    sort(edges,edges+ m,cmp);
    sum=0;
    for(int i=0;i<m;i++)
    {
        x = look(edges[i].u);
        y = look(edges[i].v);
        if(x!=y)
        {
            p[y]=x;
            sum+=edges[i].w;
            a[k++]=i;
        }
    }
    numm=k;
    uni=true;
    int r,num;
    for(k=0;k<numm;k++)
    {
        build();
        r=0;
        num=0;
        for(int i=0;i<m;i++)
        {
            if(i==a[k]) continue;
            x=look(edges[i].u);
            y=look(edges[i].v);
            if(x!=y)
            {
                p[y]=x;
                r+=edges[i].w;
                num++;
            }
        }
        if(num!=numm) continue;
        if(r==sum)
        {
            uni=false;
            return;
        }
    }
}


int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        for(int i=0;i<m;i++)
            scanf("%d%d%d", &edges[i].u, &edges[i].v, &edges[i].w);
        kruskal();
        if(!uni) printf("Not Unique!\n");
        else printf("%d\n",sum);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值